Project

General

Profile

action #80418

openQA Project - coordination #39719: [saga][epic] Detection of "known failures" for stable tests, easy test results review and easy tracking of known issues

coordination #77899: [epic] Extend "auto-review" for failed jobs as well

[learning] Fix parse errors in "openqa-investigate" "parse error: Invalid numeric literal at line 1, column 10"

Added by okurz 7 months ago. Updated 7 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
Start date:
2020-11-26
Due date:
% Done:

0%

Estimated time:

Description

Motivation

logs from "openqa-investigate" like in https://gitlab.suse.de/openqa/auto-review/-/jobs/293605/raw show that the "404 Not found" page of openQA is shown and then "parse error: Invalid numeric literal at line 1, column 10". . Probably a regression due to changed style in openQA

Steps to reproduce

Call "openqa-investigate" on any incomplete or failed job, e.g.

echo https://openqa.opensuse.org/tests/1484497 | env dry_run=1 ./openqa-investigate

Acceptance criteria

  • AC1: No errors, correct text added after ":"

Suggestions

  • Reproduce the error and fix

History

#1 Updated by mkittler 7 months ago

  • Assignee set to mkittler

#2 Updated by mkittler 7 months ago

  • Status changed from Workable to In Progress

Looks like there are multiple problems:

  1. It is using …/investigate instead of …/investigate_ajax.
  2. It doesn't handle client errors passing 404 pages to jq.
  3. It passes a JSON object to the client where a job ID is expected.¹

¹

+++ openqa-client --json-output --host https://openqa.opensuse.org 'jobs/{
  "link": "/tests/1483837",
  "text": 1483837,
  "type": "link"
}'

#4 Updated by mkittler 7 months ago

  • Status changed from In Progress to Resolved

The PR has been merged. The trigger investigation jobs pipeline passes so I guess this is resolved.

Also available in: Atom PDF