Project

General

Profile

action #73486

Package devel:openQA:Leap:15.2/perl-DBD-Pg failed to build in openSUSE_Leap_15.2/ppc64le

Added by okurz 9 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2020-10-18
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

https://build.opensuse.org/package/live_build_log/devel:openQA:Leap:15.2/perl-DBD-Pg/openSUSE_Leap_15.2/ppc64le shows

Package devel:openQA:Leap:15.2/perl-DBD-Pg failed to build in openSUSE_Leap_15.2/ppc64le

Check out the package for editing:
  osc checkout devel:openQA:Leap:15.2 perl-DBD-Pg

Last lines of build log:
[  205s] [16:39:53] t/09arrays.t ........... ok      881 ms ( 0.04 usr  0.01 sys +  0.44 cusr  0.05 csys =  0.54 CPU)
[  205s] [16:39:53] t/10_pg_error_field.t .. ok      729 ms ( 0.05 usr  0.00 sys +  0.54 cusr  0.06 csys =  0.65 CPU)
[  207s] [16:39:55] t/12placeholders.t ..... ok     1612 ms ( 0.10 usr  0.00 sys +  0.49 cusr  0.51 csys =  1.10 CPU)
[  207s] [16:39:55] t/20savepoints.t ....... ok      422 ms ( 0.00 usr  0.00 sys +  0.31 cusr  0.03 csys =  0.34 CPU)
[  209s] [16:39:57] t/30unicode.t .......... ok     1629 ms ( 0.13 usr  0.00 sys +  0.72 cusr  0.03 csys =  0.88 CPU)
[  210s] [16:39:58] t/99cleanup.t .......... ok      806 ms ( 0.01 usr  0.00 sys +  0.45 cusr  0.16 csys =  0.62 CPU)
[  210s] [16:39:58]
[  210s] 
[  210s] Test Summary Report
[  210s] -------------------
[  210s] t/08async.t          (Wstat: 65280 Tests: 55 Failed: 0)
[  210s]   Non-zero exit status: 255
[  210s]   Parse errors: Bad plan.  You planned 67 tests but ran 55.
[  210s] Files=17, Tests=2970, 53 wallclock secs ( 0.68 usr  0.21 sys + 11.60 cusr  5.97 csys = 18.46 CPU)
[  210s] Result: FAIL
[  210s] Failed 1/17 test programs. 0/2970 subtests failed.
[  210s] make: *** [Makefile:981: test_dynamic] Error 255
[  210s] error: Bad exit status from /var/tmp/rpm-tmp.Z67upJ (%check)
[  210s] 

I am sure I have seen this in the past already.

Acceptance criteria

  • AC1: Tests in package do not fail (and do not alarm us)

Suggestions

  • Check with upstream if the issue is known
  • Exclude the test from package build rules, at least for ppc64le

History

#1 Updated by okurz 2 months ago

  • Status changed from Workable to Resolved
  • Assignee set to okurz

Also available in: Atom PDF