Project

General

Profile

action #73405

job incompletes with "(?s)openqaworker8.*terminated prematurely.*OpenCV Error: Insufficient memory"

Added by Xiaojing_liu 10 months ago. Updated 9 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
Start date:
2020-10-15
Due date:
% Done:

0%

Estimated time:

Description

Observation

The job https://openqa.suse.de/tests/4827357 is incomplete, the reason is "terminated prematurely"
we could get more details in autoinst-log.txt:

[0m[2020-10-14T18:01:02.480 CEST] [debug] tests/x11/x11_setup.pm:24 called testapi::select_console -> lib/susedistribution.pm:860 called x11utils::ensure_unlocked_desktop -> lib/x11utils.pm:79 called testapi::assert_screen
[2020-10-14T18:01:02.480 CEST] [debug] <<< testapi::assert_screen(mustmatch=[
  "displaymanager",
  "displaymanager-password-prompt",
  "generic-desktop",
  "screenlock",
  "screenlock-password",
  "authentication-required-user-settings",
  "authentication-required-modify-system",
  "guest-disabled-display",
  "oh-no-something-has-gone-wrong"
], no_wait=1, timeout=30)
OpenCV Error: Insufficient memory (Failed to allocate 6305800 bytes) in OutOfMemoryError, file /home/abuild/rpmbuild/BUILD/opencv-3.3.1/modules/core/src/alloc.cpp, line 55
OpenCV Error: Assertion failed (u != 0) in create, file /home/abuild/rpmbuild/BUILD/opencv-3.3.1/modules/core/src/matrix.cpp, line 436
terminate called after throwing an instance of 'cv::Exception'
  what():  OpenCV(3.3.1) /home/abuild/rpmbuild/BUILD/opencv-3.3.1/modules/core/src/matrix.cpp:436: error: (-215:Assertion failed) u != 0 in function 'create'

[2020-10-14T18:01:06.122 CEST] [debug] backend process exited: 0
[2020-10-14T18:01:06.152 CEST] [debug] Driver backend collected unknown process with pid 8721 and exit status: 0
[2020-10-14T18:01:06.153 CEST] [debug] stopping command server 8519 because test execution ended
[2020-10-14T18:01:06.154 CEST] [debug] isotovideo: informing websocket clients before stopping command server: http://127.0.0.1:20143/ystfRO1E6GtU2IpV/broadcast
[2020-10-14T18:01:06.175 CEST] [debug] commands process exited: 0
[2020-10-14T18:01:06.276 CEST] [debug] done with command server
[2020-10-14T18:01:06.276 CEST] [debug] stopping autotest process 8531
[2020-10-14T18:01:06.277 CEST] [debug] autotest received signal TERM, saving results of current test before exiting
[2020-10-14T18:01:06.298 CEST] [debug] [autotest] process exited: 1
[2020-10-14T18:01:06.398 CEST] [debug] done with autotest process
[2020-10-14T18:01:06.398 CEST] [debug] isotovideo failed
[2020-10-14T18:01:06.399 CEST] [debug] stopping backend process 8626
[2020-10-14T18:01:06.399 CEST] [debug] done with backend process
8513: EXIT 1

see: https://openqa.suse.de/tests/4827357/file/autoinst-log.txt


Related issues

Related to openQA Infrastructure - action #73246: [osd-admins][alert] openqaworker8: Memory usage alertResolved2020-10-122020-10-23

History

#1 Updated by Xiaojing_liu 10 months ago

  • Subject changed from job incompletes with auto_review:"terminated prematurely .*" to job incompletes with auto_review:"terminated prematurely.*"

#2 Updated by okurz 10 months ago

  • Related to action #73246: [osd-admins][alert] openqaworker8: Memory usage alert added

#3 Updated by okurz 10 months ago

  • Project changed from openQA Project to openQA Infrastructure
  • Subject changed from job incompletes with auto_review:"terminated prematurely.*" to job incompletes with auto_review:"(?s)openqaworker8.*terminated prematurely.*OpenCV Error: Insufficient memory"
  • Status changed from New to Blocked
  • Assignee set to okurz
  • Target version set to Ready

I would be a bit more careful with too generic regex's. I made that very specific now. The problem is linked to #73246 and the machine running out of memory because our test maintainers overload it with RAM heavy multi-machine clusters.

#4 Updated by okurz 9 months ago

  • Subject changed from job incompletes with auto_review:"(?s)openqaworker8.*terminated prematurely.*OpenCV Error: Insufficient memory" to job incompletes with "(?s)openqaworker8.*terminated prematurely.*OpenCV Error: Insufficient memory"
  • Status changed from Blocked to Resolved

The OOM problems on openqaworker8 have been fixed.

Also available in: Atom PDF