Project

General

Profile

action #71902

Jump15.2 test fails in podman_image

Added by michel_mno about 1 year ago. Updated 12 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2020-09-25
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Observation

Jump15.2 test fails in podman_image because no images/path for Jump:15.2 in registry.

podman image inspect --format='{{.RepoTags}}' registry.opensuse.org/opensuse/leap/Jump:15.2/images/totest/containers/opensuse/leap:Jump:15.2 | grep 'registry.opensuse.org/opensuse/leap/Jump:15.2/images/totest/containers/opensuse/leap:Jump:15.2'; echo cbeOK-$?-
===
Error: error getting image "registry.opensuse.org/opensuse/leap/Jump:15.2/images/totest/containers/opensuse/leap:Jump:15.2": invalid reference format
cbeOK-1-

openQA test in scenario opensuse-Jump:15.2-DVD-x86_64-extra_tests_textmode_containers@64bit fails in
podman_image

Test suite description

Maintainer: dheidler. Extra tests about CLI software in container module

Reproducible

Fails since (at least) Build 21.5

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by michel_mno about 1 year ago

Comments from Max:

1) once we had the container images then we will know the right path
2) Jump:15.2 here is VERSION variable on openQA, we need to correct it in the openqa test

#2 Updated by michel_mno about 1 year ago

step 1 started by Fabian, with openQA images tests in https://openqa.opensuse.org/tests/overview?distri=opensuse&version=Jump%3A15.2&build=2.1&groupid=76
but blocked by https://progress.opensuse.org/issues/70957 "Maintenance setup for Jump"

#3 Updated by favogt 12 months ago

  • Status changed from New to Resolved
  • Assignee set to favogt
  • % Done changed from 0 to 100

Container tests got adjusted for Jump and all blocking product issues got fixed (except for the vendor change conflict on upgrades), so images got released.
"extra_tests_textmode_containers" is green for aarch64, ppc64le and x86_64 now.

Also available in: Atom PDF