Project

General

Profile

action #71638

[y] test fails in validate_fs_table

Added by syrianidou_sofia about 1 year ago. Updated about 1 year ago.

Status:
Rejected
Priority:
High
Assignee:
-
Category:
Bugs in existing tests
Target version:
-
Start date:
2020-09-22
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

During msdos partitioning, the SWAP partition is selected to be created with UDF instead of swap filesystem. Even though, the screen matches at swap, there is an extra key sent and the result is that SWAP partition is missing and the filesystme validation fails:

[2020-09-22T04:58:41.696 CEST] [debug] <<< testapi::check_screen(mustmatch="partitioning_swap-format-selected", timeout=5)
[2020-09-22T04:58:42.046 CEST] [debug] load of /var/lib/openqa/cache/openqa.suse.de/tests/sle/products/sle/needles/partitioning_swap-format-selected-20200217.png took 0.35 seconds
[2020-09-22T04:58:44.670 CEST] [debug] >>> testapi::_handle_found_needle: found partitioning_swap-format-selected-20200121, similarity 1.00 @ 368/351
[2020-09-22T04:58:44.670 CEST] [debug] tests/installation/partitioning/msdos_partition_table.pm:27 called Installation::Partitioner::LibstorageNG::v4::ExpertPartitionerController::add_partition_msdos -> lib/Installation/Partitioner/LibstorageNG/v4/ExpertPartitionerController.pm:168 called Installation::Partitioner::LibstorageNG::v4::ExpertPartitionerController::add_new_partition -> lib/Installation/Partitioner/LibstorageNG/v4/ExpertPartitionerController.pm:180 called Installation::Partitioner::AbstractExpertPartitionerController::_set_partition_options -> lib/Installation/Partitioner/AbstractExpertPartitionerController.pm:114 called Installation::Partitioner::FormattingOptionsPage::select_mount_device_radiobutton -> lib/Installation/Partitioner/FormattingOptionsPage.pm:96 called testapi::assert_screen
[2020-09-22T04:58:44.670 CEST] [debug] <<< testapi::assert_screen(mustmatch="partition-format", timeout=30)
[2020-09-22T04:58:44.791 CEST] [debug] >>> testapi::_handle_found_needle: found partitioning-format-20160504, similarity 1.00 @ 275/273
[2020-09-22T04:58:44.792 CEST] [debug] tests/installation/partitioning/msdos_partition_table.pm:27 called Installation::Partitioner::LibstorageNG::v4::ExpertPartitionerController::add_partition_msdos -> lib/Installation/Partitioner/LibstorageNG/v4/ExpertPartitionerController.pm:168 called Installation::Partitioner::LibstorageNG::v4::ExpertPartitionerController::add_new_partition -> lib/Installation/Partitioner/LibstorageNG/v4/ExpertPartitionerController.pm:180 called Installation::Partitioner::AbstractExpertPartitionerController::_set_partition_options -> lib/Installation/Partitioner/AbstractExpertPartitionerController.pm:114 called Installation::Partitioner::FormattingOptionsPage::select_mount_device_radiobutton -> lib/Installation/Partitioner/FormattingOptionsPage.pm:97 called testapi::send_key
[2020-09-22T04:58:44.792 CEST] [debug] <<< testapi::send_key(key="alt-o", do_wait=0, wait_screen_change=0)

https://openqa.suse.de/tests/4711745#step/msdos_partition_table/86

https://openqa.suse.de/tests/4711745/modules/validate_fs_table/steps/35

Test suite description

Installation with MSDOS partition table.

Reproducible

Fails since (at least) Build 33.1

Expected result

Last good: 23.1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by syrianidou_sofia about 1 year ago

  • Subject changed from [y] test fails in validate_fs_table to [y] test fails in validate_fs_table on ppc64le

#2 Updated by syrianidou_sofia about 1 year ago

  • Status changed from New to Rejected

#3 Updated by syrianidou_sofia about 1 year ago

  • Subject changed from [y] test fails in validate_fs_table on ppc64le to [y] test fails in validate_fs_table

Also available in: Atom PDF