Project

General

Profile

action #68236

Provide metric about "time to start of tests" on OSD

Added by okurz over 1 year ago. Updated over 1 year ago.

Status:
Rejected
Priority:
Normal
Assignee:
Target version:
-
Start date:
2020-06-19
Due date:
% Done:

0%

Estimated time:

Description

Motivation

There is a plan to provide more metrics within SUSE, e.g. see https://confluence.suse.com/pages/viewpage.action?pageId=156401717#RalfUnger%E2%80%99sHome-Ideasby , and as we already use grafana we should be able to gather data from there.

Acceptance criteria

  • AC1: Time to start of tests on openqa.suse.de is provided automatically

Suggestions

Time to starting of tests on openqa.suse.de (how long does it take maximum that a test on openqa.suse.de starts; purpose: How users/teams/departments can integrate openQA tests into their own processes; data source: openQA database queries or existing data on https://stats.openqa-monitor.qa.suse.de;presentation: time ranges as statistical values, e.g. mean+-std, median, percentiles as numbers as well as graphs for progress)


Related issues

Is duplicate of openQA Infrastructure - action #65975: Monitoring for "scheduled but not executed" (was: perl-Mojolicious-8.37 broke WS connection for (some?) workers)Resolved2020-04-222020-10-07

History

#1 Updated by okurz over 1 year ago

  • Is duplicate of action #65975: Monitoring for "scheduled but not executed" (was: perl-Mojolicious-8.37 broke WS connection for (some?) workers) added

#2 Updated by okurz over 1 year ago

  • Status changed from New to Rejected
  • Assignee set to okurz

that's actually the same as #65975 , merging as duplicate

Also available in: Atom PDF