Project

General

Profile

action #67486

Test invisAD-setup-14 (14.2) with openSUSE Leap 15.2

Added by flacco about 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Feature
Target version:
Start date:
2020-05-30
Due date:
2020-06-06
% Done:

100%

Estimated time:

Description

openSUSE Leap 15.2 is nearly ready. There is a release candidate available.

We should test the new 14.2 invis-server setup on leap 15.2.

It should be possible to install an invis-server 14.2 on both maintained openSUSE leap versions

History

#1 Updated by flacco about 1 year ago

  • % Done changed from 0 to 10

First test fails during the installation of our samba packages. This is caused by newer samba and ldb versions in 15.2 than our own packages.

We have already started to build samba 4.12. packages

#2 Updated by flacco about 1 year ago

Next dependency problem. sssd-ad from openSUSE leap 15.x requires libndr0 from samba, but samba 4.12 provides libndr1.

#3 Updated by flacco about 1 year ago

It's not possible to install the kopano-limited packages in openSUSE leap 15.2 caused by several unresolved dependencies.

Setup Kopano Community from OBS seems to work now, but the webapp is much to old.

#4 Updated by flacco about 1 year ago

  • % Done changed from 10 to 50

#5 Updated by flacco about 1 year ago

Samba AD Setup with our new 4.12.x packages works

#6 Updated by flacco about 1 year ago

  • % Done changed from 50 to 70

New own Samba and sssd packages works with openSUSE Leap 15.1 and 15.2. No Problems yet.

#7 Updated by flacco about 1 year ago

  • Status changed from New to Closed
  • % Done changed from 70 to 100

There is a problem with openSUSE Leap 15.2 and the supported kopano packages. Kopano ships version 8.7.x as officially supported version. The community version at the moment is 10.0.x. openSUSE leap 15.2 ships some libraries like "libicu", "libical" and some more which are to new for Kopano 8.7.x. Trying to build a lot of "old" libraries for openSUSE leap 15.2 is not a very good idea, so we don't do this.

In summary this means, that invis-server 14.2 is only compatible with leap 15.2 if it is installed with the Kopano community packages shipped by leap or without Kopano. invis-Server 14.2 is compatible with leap 15.2 under this conditions.

This will change if the officially shipped Kopano packages reaches version 10.0.x or better are build especially for leap 15.2.

I close this ticket by now.

Also available in: Atom PDF