Project

General

Profile

action #67102

[SLE][Migration][SLE15SP2]test fails in bootloader - maybe need more time to wait boot?

Added by coolgw over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2020-05-21
Due date:
% Done:

100%

Estimated time:
12.00 h
Difficulty:

Description

Observation

openQA test in scenario sle-15-SP2-Migration-from-SLE15-SPX-to-SLE15-SP2-ppc64le-offline_sles15sp1_pscc_basesys-srv-desk-dev_all_full@ppc64le fails in
bootloader

Test suite description

basesys+srv+desk+dev all p1/c/c

Reproducible

Fails since (at least) Build 197.1

Expected result

Last good: 195.1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by coolgw over 2 years ago

  • Assignee changed from coolgw to leli

#2 Updated by leli over 2 years ago

  • Estimated time set to 12.00 h

Maybe we need add wait_boot after 'reboot' run.

#3 Updated by leli over 2 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 20

#4 Updated by leli over 2 years ago

Try to use wait_grub since wait_boot will include the bootloader process. http://openqa.nue.suse.com/tests/4268534#details

#5 Updated by leli over 2 years ago

  • % Done changed from 20 to 60

PR submitted. https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/10350

I choose assert boot menu to ensure fix this issue.

#6 Updated by coolgw over 2 years ago

your fix can cover following situation or not?
https://openqa.nue.suse.com/tests/4273447#

#7 Updated by leli over 2 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 60 to 100

PR merged and verified on OSD. https://openqa.nue.suse.com/tests/4274244

Also available in: Atom PDF