Project

General

Profile

action #63136

Use reference with API requests to protect against mid-air collisions

Added by cdywan 5 months ago. Updated 7 days ago.

Status:
Resolved
Priority:
Low
Assignee:
Start date:
2020-02-05
Due date:
% Done:

0%

Estimated time:
Duration:

Description

The reference parameter allows the API to verify that the current state in the database matches the state expected by the consumer.

MR: gl#qsf-u/qa-sle-functional-userspace#29

History

#1 Updated by okurz 4 months ago

bump

#2 Updated by okurz 4 months ago

There is https://gitlab.suse.de/qsf-u/qa-sle-functional-userspace/-/merge_requests/29 and no one responded within 3 weeks. This is either a big overlook on the side of the corresponding team or they just don't like you ;) In any case also the pipeline job seems to have failed. So what do you plan as next steps?

#3 Updated by cdywan 4 months ago

Conversation with upstream and update to my branch in progress - turns out my original approach was way to complicated.

#4 Updated by cdywan 4 months ago

  • Status changed from In Progress to Feedback

#5 Updated by cdywan 4 months ago

  • Status changed from Feedback to In Progress

Unfortunately the change had to be reverted because of a regression. I proposed a PR to address this:

https://github.com/os-autoinst/openQA/pull/2844

#7 Updated by cdywan 2 months ago

Turns out git/ GitLab CI is making what should've been a simple fix quite a challenge.

  • There's no origin/master on GitLab CI
  • git fetch fails because it's not configured
  • git show doesn't fail even when it fails
  • CI_COMMIT_BEFORE_SHA doesn't work and isn't well-documented

#8 Updated by cdywan 2 months ago

  • Status changed from In Progress to Feedback

I'm putting this on Feedback now, on account of having exhausted all the options.

Maybe the feature isn't feasible on GitLab? Maybe we need a different approach?

#9 Updated by tinita 2 months ago

I created https://gitlab.suse.de/qsf-u/qa-sle-functional-userspace/-/merge_requests/78

I think it's not very nice having to compose the repo URL ourselves, but it works.

#10 Updated by cdywan 2 months ago

  • Status changed from Feedback to In Progress
  • Assignee changed from cdywan to tinita

#11 Updated by cdywan about 1 month ago

  • Status changed from In Progress to Feedback

There's also an alternative proposal https://gitlab.suse.de/qsf-y/qa-sle-functional-y/-/merge_requests/166 which means this is pending on upstream's call on which to go for now.

#12 Updated by okurz 7 days ago

No update in the MR https://gitlab.suse.de/qsf-y/qa-sle-functional-y/-/merge_requests/166 but I guess we can just give it more time.

#13 Updated by cdywan 7 days ago

  • Status changed from Feedback to Resolved

We can in fact close this. Ultimately the protection against unexpected changes doesn't fit the workflow very well, at least for QASFY.

Also available in: Atom PDF