Project

General

Profile

action #62546

old files kept in pontifex2:/srv/ftp/pub/opensuse/distribution/leap/15.2/repo/oss/

Added by bmwiedemann 9 months ago. Updated 8 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Infrastructure
Target version:
Start date:
2020-01-22
Due date:
% Done:

0%

Estimated time:

Description

I found that there are many old files kept in pontifex2:/srv/ftp/pub/opensuse/distribution/leap/15.2/repo/oss/

time ls -l /srv/ftp/pub/opensuse/distribution/leap/15.2/repo/oss/x86_64/|wc
111800 1006193 10718652

real 1m18.951s
user 0m1.206s
sys 0m2.576s

vs the 20 k files in 15.1

OBS team (Marco) said, they upload their files to pontifex2 and there is only the latest version in the upload dir.

History

#1 Updated by lnussel 9 months ago

  • Assignee changed from lnussel to lkocman

the cleanup script is probably not set up correctly

#2 Updated by lkocman 8 months ago

Thank you very much for reporting this issue. I've forwarded it to heroes@opensuse.org as I currently don't have ssh access there (requested right away via infra@suse.de).

#3 Updated by pjessen 8 months ago

Hi Lubos

I think it might be an rsync option on the sending side? Granted, I am not intimately familiar with everything that happens on download.o.o, but I don't remember fiddling with any such cleanup for leap 15.1.

#4 Updated by pjessen 8 months ago

pjessen wrote:

Hi Lubos

I think it might be an rsync option on the sending side? Granted, I am not intimately familiar with everything that happens on download.o.o, but I don't remember fiddling with any such cleanup for leap 15.1.

Missing a -delete{-after,-before} option maybe ?

#5 Updated by lkocman 8 months ago

Yes that's what I was thinking about as well. Let me find out what tool/script is calling rsync.

#6 Updated by lkocman 8 months ago

Seems like the publisher is owned by OBS team. I did create a github issue and pinged team on #dist https://github.com/openSUSE/open-build-service/issues/9097

#7 Updated by lnussel 8 months ago

It's https://github.com/openSUSE/publish_distro in ~mirror and not OBS' fault. Unfortunately github doesn't let me comment on the issue. You can close it. The problem is on pontifex side.

#8 Updated by lkocman 8 months ago

  • Status changed from New to Resolved

Response from Rudi

Lubos Kocman looks like you are aware, just to make sure. OBS already syncs to the staging area on pontifex with --delete, the problem was local on pontifex where the cleanup after syncing from stage to prime was missing (normally it deletes the older files after 3 days). I think we fixed the issue yesterday evening, so the next cleanup should run in the normal schedule in two days now

So I take that it's resolved.

Also available in: Atom PDF