action #60008

[openqa-in-openqa] test fails in test_distribution due to zypper failing on a devel repo during fetching. Need retry in zypper

Added by okurz 5 months ago. Updated 3 months ago.

Status:ResolvedStart date:19/11/2019
Priority:NormalDue date:
Assignee:tinita% Done:

80%

Category:Bugs in existing tests
Target version:openQA Project - Current Sprint
Difficulty:
Duration:

Description

Observation

openQA test in scenario openqa-Tumbleweed-dev-x86_64-openqa_install+publish@64bit-2G fails in
test_distribution

Test suite description

Maintainer: okurz@suse.de
Test for installation of openQA itself. To be used with "openqa" distri.

Publishes an qcow2 image including the openQA installation ready to run as an appliance.

Reproducible

Fails since (at least) Build :TW.3449 (current job)

Expected result

Last good: :TW.3448 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #62009: [openqa-in-openqa] test fails in openqa_worker during a z... Resolved 10/01/2020

History

#1 Updated by tinita 5 months ago

  • Status changed from New to In Progress
  • Assignee set to tinita
  • Target version set to Current Sprint

#3 Updated by tinita 5 months ago

  • Status changed from In Progress to Feedback
  • % Done changed from 0 to 80

#5 Updated by okurz 4 months ago

  • Status changed from Feedback to Resolved

Merged. Thank you. Verification on production: https://openqa.opensuse.org/tests/1090694

#6 Updated by okurz 4 months ago

  • Status changed from Resolved to Feedback

@tinita https://openqa.opensuse.org/tests/1092187#step/test_distribution/6 shows that it was not just missing auto-refresh. I put another comment in https://github.com/openSUSE/zypper/issues/312#issuecomment-557444862 . It seems we need the retry after all but now we can reference the github issue with record_soft_failure. Care to do this?

#7 Updated by tinita 4 months ago

okurz wrote:

It seems we need the retry after all but now we can reference the github issue with record_soft_failure. Care to do this?

Maybe we should wait for an explanation in the referenced issue.
Also I'm not sure yet how to do the retry. My solution in bash in my first PR was not the way to go obviously.

#8 Updated by okurz 4 months ago

Your initial PR was fine except that 1. We were told "there is no problem when we refresh" which is apparently not true and 2. we should use the retry in all occassions of using zypper or zypper in at least. So please feel welcome to try a change again or unassign the ticket otherwise.

#9 Updated by tinita 4 months ago

#11 Updated by okurz 4 months ago

  • Status changed from Feedback to Resolved

https://openqa.opensuse.org/tests/1097279#step/test_distribution/4 shows the successful execution of zypper ref -f in a production test. As previously the test was also not failing that often I think we should be ok to mark it as resolved now but reopen it when we see that we actually still need a retry for zypper. Thank you.

#12 Updated by tinita 3 months ago

The openqa_worker test failed yesterday because of the same problem: https://openqa.opensuse.org/tests/1136753#step/openqa_worker/6
Seems we need a zypper refresh there also.

#13 Updated by tinita 3 months ago

  • Related to action #62009: [openqa-in-openqa] test fails in openqa_worker during a zypper install added

Also available in: Atom PDF