Project

General

Profile

Actions

action #59172

closed

[sle][Migration][SLE15SP2] test fails in zypper_patch - failed to switch to desktop

Added by leli over 4 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
Urgent
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2019-11-07
Due date:
% Done:

100%

Estimated time:
16.00 h
Difficulty:

Description

Observation

openQA test in scenario sle-15-SP2-Migration-from-SLE15-SPX-to-SLE15-SP2-x86_64-online_sles15sp1_pscc_basesys-srv-live-tsm_all_full_zypp@64bit fails in
zypper_patch

Test suite description

basesys+srv+live+tsm all p1/c/z

Reproducible

Fails since (at least) Build 72.1

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest


Related issues 1 (1 open0 closed)

Related to openQA Tests - action #46394: [sle][s390x][spvm][kvm][sporadic] test fails in various modules to login to svirt console (or system is not up yet)Workable

Actions
Actions #1

Updated by hjluo over 4 years ago

  • Status changed from New to In Progress
  • Assignee set to hjluo

#we need to fix this issue cause it block some case in our sles15sp2.
[ 890.149472] systemd[1]: Starting Virtualization daemon...
[ 890.232674] libvirtd[4919]: 2019-11-06 14:35:05.591+0000: 4919: info : libvirt version: 5.1.0
[ 890.235947] libvirtd[4919]: 2019-11-06 14:35:05.591+0000: 4919: info : hostname: susetest
[ 890.238697] libvirtd[4919]: 2019-11-06 14:35:05.591+0000: 4919: warning : virGetHostnameImpl:713 : getaddrinfo failed for 'susetest': Name or service not known
[ 890.313922] systemd[1]: Started Virtualization daemon.

Test died: no candidate needle with tag(s) 'generic-desktop, emergency-shell, emergency-mode' matched

Hit this again while fix switch_to_tty6: https://openqa.suse.de/tests/3567287#step/patch_sle/201

Actions #2

Updated by leli over 4 years ago

  • Subject changed from [sle][Migration][SLE15SP2] test fails in zypper_patch - failed to swich to desktop to [sle][Migration][SLE15SP2] test fails in zypper_patch - failed to switch to desktop
Actions #3

Updated by hjluo over 4 years ago

  • % Done changed from 0 to 40
Actions #4

Updated by hjluo over 4 years ago

  • % Done changed from 40 to 60
Actions #6

Updated by hjluo over 4 years ago

  • % Done changed from 60 to 70
Actions #8

Updated by hjluo over 4 years ago

these 3 case's failures was caused by not setting DESKTOP=gnome:

https://openqa.suse.de/tests/3597304#step/online_migration_setup/27
https://openqa.suse.de/tests/3590328#step/online_migration_setup/8
https://openqa.suse.de/tests/3590352#step/online_migration_setup/8

and verified by adding that setting to the test case. it's not related to this issue.

Actions #9

Updated by coolgw over 4 years ago

Base oliver's feedback on PR, should we further check log of test case to confirm whether product issue?
Another side, i suggest we need further check failed rate of this case.

Actions #10

Updated by leli over 4 years ago

  • Priority changed from Normal to High
Actions #11

Updated by hjluo over 4 years ago

tried a failed case https://openqa.suse.de/tests/3598328 and it passed with the fix
https://openqa.suse.de/tests/3635304

Actions #12

Updated by hjluo over 4 years ago

and this one:
This bug is still referenced in a failing openQA test: offline_sles15_media_basesys-srv-lgm-pcm_def_full
https://openqa.suse.de/tests/3598328

Verified run with the PR#8880 https://openqa.suse.de/tests/3635304

Actions #13

Updated by hjluo about 4 years ago

  • % Done changed from 70 to 100

With the merge of the PR afffd64, which fixed the "wait_boot: Simplify by extracting methods". we close this PR and will watch for this kind of error, if it still reproduce we will fix it again.

https://github.com/os-autoinst/os-autoinst-distri-opensuse/commit/afffd640cc8e37adbad83485274c25ae971ff2e8

Actions #14

Updated by hjluo about 4 years ago

  • Status changed from In Progress to Resolved
Actions #15

Updated by hjluo about 4 years ago

Actions #16

Updated by leli almost 4 years ago

  • Status changed from Resolved to Workable
  • % Done changed from 100 to 0
Actions #17

Updated by leli almost 4 years ago

  • Priority changed from High to Urgent
Actions #18

Updated by hjluo almost 4 years ago

this kind of issue is sporadic need rerun https://openqa.nue.suse.com/tests/3973565 and passed.

Actions #19

Updated by hjluo almost 4 years ago

  • Related to action #46394: [sle][s390x][spvm][kvm][sporadic] test fails in various modules to login to svirt console (or system is not up yet) added
Actions #20

Updated by hjluo almost 4 years ago

  • Status changed from Workable to Rejected
  • % Done changed from 0 to 100

we can use poo#46394 for this kind of issue and close this one.
https://progress.opensuse.org/issues/46394
[sle][functional][u][s390x][spvm][kvm][sporadic] test fails in various modules to login to svirt console (or system is not up yet)

Actions

Also available in: Atom PDF