Project

General

Profile

action #58601

[qam]test fails in qa_test_klp (kernel source version mismatch)

Added by MDoucha almost 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2019-10-23
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-Server-DVD-Incidents-Kernel-ppc64le-kernel-live-patching@ppc64le-virtio fails in
qa_test_klp

The VM image was installed for kernel build 1760 but the test job was stuck in queue for too long and a new kernel build became available in the mean time. When the test finally started, the test job installed kernel source for build 1761. The live patch compiler then couldn't find the kernel sources and the job failed.

Solution: Read running kernel version from uname and always install specific version of kernel sources.

Test suite description

qa_test_klp, test of Kernel Livepatching Infrastructure

Reproducible

Fails since (at least) Build 4.12.14-1760.1.gcb14640 (current job)

Expected result

Last good: 4.12.14-1754.1.g481da9b (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by MDoucha almost 2 years ago

  • Subject changed from test fails in qa_test_klp (kernel source version mismatch) to [qam]test fails in qa_test_klp (kernel source version mismatch)
  • Assignee set to MDoucha

#2 Updated by MDoucha almost 2 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 80

#3 Updated by MDoucha almost 2 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 80 to 100

Also available in: Atom PDF