action #55424

Error about "Use of uninitialized value in join or string at template branding/openSUSE/external_reporting.html.ep line 45" on every view of a screenshot of a job that has non-standard flavor, e.g. "Regression-on-migrated-system-from-SLE12-SPx"

Added by okurz 8 months ago. Updated 8 months ago.

Status:ResolvedStart date:13/08/2019
Priority:LowDue date:
Assignee:okurz% Done:

0%

Category:Concrete Bugs
Target version:-
Difficulty:
Duration:

Description

Observation

Every time someone accesses a screenshot view of a job with a "non-standard" flavor, e.g. https://openqa.suse.de/tests/3240939#step/install_service/5 with flavor "Regression-on-migrated-system-from-SLE12-SPx" an error is reported in logs about

Use of uninitialized value in join or string at template branding/openSUSE/external_reporting.html.ep line 45.

Related issues

Related to openQA Project - action #51989: Use of uninitialized value $distri in branding/openSUSE/e... Resolved 25/05/2019
Related to openQA Project - action #54806: [epic] Better user control over job group overview New 30/07/2019

History

#1 Updated by okurz 8 months ago

  • Related to action #51989: Use of uninitialized value $distri in branding/openSUSE/external_reporting.html.ep , uncovered "microos" distri causes warning and bug report icon to not show up added

#2 Updated by okurz 8 months ago

  • Related to action #54806: [epic] Better user control over job group overview added

#3 Updated by okurz 8 months ago

  • Status changed from New to Feedback
  • Assignee set to okurz

To fall back to flavor "Server" if the lookup turns out empty. Updated still open https://github.com/os-autoinst/openQA/pull/2253

hotpatched osd to prevent further error to help not to distract from #54902 :)

#4 Updated by okurz 8 months ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF