Project

General

Profile

action #54557

All openQA tests incomplete but neither package build nor unit tests fail when a new file is added to os-autoinst without mentioning in Makefile.am

Added by okurz over 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Feature requests
Target version:
Start date:
2019-07-23
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

See e.g. https://openqa.opensuse.org/tests/988325/file/autoinst-log.txt failing with

Can't locate consoles/ssh_screen.pm in @INC (you may need to install the consoles::ssh_screen module) (@INC contains: /var/lib/openqa/cache/openqa1-opensuse/tests/opensuse/products/opensuse/../../lib /var/lib/openqa/cache/openqa1-opensuse/tests/opensuse/lib /var/lib/openqa/pool/16/blib/arch /var/lib/openqa/pool/16/blib/lib /usr/lib/os-autoinst /usr/lib/perl5/site_perl/5.26.1/x86_64-linux-thread-multi /usr/lib/perl5/site_perl/5.26.1 /usr/lib/perl5/vendor_perl/5.26.1/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.26.1 /usr/lib/perl5/5.26.1/x86_64-linux-thread-multi /usr/lib/perl5/5.26.1 /usr/lib/perl5/site_perl) at /usr/lib/os-autoinst/consoles/sshVirtshSUT.pm line 25.
BEGIN failed--compilation aborted at /usr/lib/os-autoinst/consoles/sshVirtshSUT.pm line 25.

caused by https://github.com/os-autoinst/os-autoinst/pull/1176 . What is interesting is that neither the self-tests in the the project nor any package builds or self-tests in https://build.opensuse.org/package/show/devel:openQA/os-autoinst fail.

Acceptance criteria

  • AC1: Any tests or checks prevent a new os-autoinst package to be installed if a new file was added but not referenced in the Makefile for installation

Related issues

Related to openQA Project - coordination #62420: [epic] Distinguish all types of incompletesResolved2018-12-12

History

#1 Updated by okurz almost 2 years ago

#2 Updated by okurz over 1 year ago

Happened again with https://github.com/os-autoinst/os-autoinst/pull/1456 causing the same kind of severe problems. https://github.com/os-autoinst/os-autoinst/pull/1464 created as an immediate fix for the introduced problem but not a solution preventing this in the future again. Hopefully OBS checks in pull requests will cover this in the future but maybe we can have a simple script that statically checks files. Triggered on o3: for i in aarch64 openqaworker1 openqaworker4 openqaworker7 power8 imagetester rebel; do echo $i && ssh root@$i "(transactional-update -n dup || zypper -n dup) && reboot" ; done. Retriggered incompletes using https://github.com/os-autoinst/scripts/pull/28 and failed_since=2020-07-10 additional_filters="clone_id is null and reason ~ 'died'" ./openqa-restart-incompletes-on-worker-instance

#3 Updated by okurz over 1 year ago

  • Status changed from New to Feedback
  • Assignee set to okurz

#4 Updated by okurz over 1 year ago

PR merged but based on feedback trying one step further: https://github.com/os-autoinst/os-autoinst/pull/1469

#5 Updated by okurz over 1 year ago

  • Target version set to Ready

Also available in: Atom PDF