Project

General

Profile

action #51869

Build new own Samba-packages

Added by flacco about 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
2019-05-22
Due date:
% Done:

100%

Estimated time:

Description

Caused by problems with the MIT-Kerberos implementation and it's "experimental" state, we must build again own Samba-packages with Heimdal-Kerberos and switch our setup back to these own packages.

History

#1 Updated by flacco about 3 years ago

  • % Done changed from 10 to 20

New testing repository is already created:

https://build.opensuse.org/project/show/spins:invis:15:testing:samba47

There are still build problems with samba 4.7.12

#2 Updated by flacco about 3 years ago

  • Description updated (diff)

#3 Updated by flacco about 3 years ago

  • Description updated (diff)

#4 Updated by flacco almost 3 years ago

  • % Done changed from 20 to 40

Samba 4.10 is running but runs in errors:

May 30 14:05:03 invis samba[20923]: /usr/sbin/samba_dnsupdate: import dns.resolver
May 30 14:05:03 invis samba[20923]: [2019/05/30 14:05:03.936029, 0] ../../lib/util/util_runcmd.c:327(samba_runcmd_io_handler)
May 30 14:05:03 invis samba[20923]: /usr/sbin/samba_dnsupdate: ModuleNotFoundError: No module named 'dns'
May 30 14:05:04 invis samba[20923]: [2019/05/30 14:05:04.021991, 0] ../../source4/dsdb/dns/dns_update.c:331(dnsupdate_nameupdate_done)
May 30 14:05:04 invis samba[20923]: dnsupdate_nameupdate_done: Failed DNS update with exit code 1

#5 Updated by flacco almost 3 years ago

OK, the package python3-dnspython was missing. We should add this into the samba package dependencies.

#6 Updated by flacco almost 3 years ago

New Requirement added to spec-file.

#7 Updated by flacco almost 3 years ago

Building new apparmor-Profiles is in progress.

#8 Updated by flacco almost 3 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 40 to 100

Done. We switched to Samba 4.10.x

Also available in: Atom PDF