Project

General

Profile

action #50486

[opensuse][functional][u] test fails in sssd - No module name pam

Added by lnussel over 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
High
Category:
Bugs in existing tests
Target version:
-
Start date:
2019-04-17
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

ImportError: No module named pam
###junit failure time="2019-04-16T11:42:56.337" type="Failed to authentication testuser1"

The tests are trying to run with python2. But, on SLE15 and Tumbleweed python3 should be used. The tests are adapted for SLE15 but not for Tumbleweed.

Reproducible

Fails since Build 451.2
in scenario opensuse-15.1-DVD-x86_64-extra_tests_in_textmode@64bit

Expected result

Last good: 450.2

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #33082: [sle][functional][u] sysauth/sssd is not scheduled on osdResolved2019-04-17

Has duplicate openQA Tests - action #50678: test fails in sssd - seems due to python2/3 dep change?Rejected2019-04-24

History

#1 Updated by SLindoMansilla over 3 years ago

  • Subject changed from test fails in sssd to [opensuse][functional][u] test fails in sssd - No module name pam
  • Description updated (diff)
  • Priority changed from Normal to High

As a result of backlog triaging (see https://progress.opensuse.org/projects/openqatests/wiki#ticket-backlog-triaging for more information).

Please, feel free to adjust the category or the "[label]" if you think different.

#2 Updated by lnussel over 3 years ago

any ETA for a fix?

#3 Updated by SLindoMansilla over 3 years ago

  • Has duplicate action #50678: test fails in sssd - seems due to python2/3 dep change? added

#4 Updated by SLindoMansilla over 3 years ago

  • Description updated (diff)
  • Assignee set to SLindoMansilla
  • Priority changed from High to Immediate

I simply added to the queue of tickets to be reviewed. It hadn't any special priority. But, since you ask for ETA and a duplicate was created, it looks important. I will take a look.

Note for the future, if you mark a ticket for u-team as urgent or immediate, someone will look at it in 24/48 hours. ;)

#5 Updated by SLindoMansilla over 3 years ago

  • Description updated (diff)
  • Status changed from New to Workable
  • Priority changed from Immediate to Urgent

ETA for a PR, today.

#7 Updated by SLindoMansilla over 3 years ago

  • Status changed from Workable to Feedback
  • Priority changed from Urgent to High

Waiting for PR to be merged

#8 Updated by SLindoMansilla over 3 years ago

  • Related to action #33082: [sle][functional][u] sysauth/sssd is not scheduled on osd added

#9 Updated by SLindoMansilla over 3 years ago

  • Status changed from Feedback to In Progress

Leap 15.1 and SLE12-SP5 are also affected by this.

#12 Updated by SLindoMansilla about 3 years ago

  • Status changed from In Progress to Resolved

SLE12-SP5 is working with python2 yet: https://openqa.suse.de/tests/2881002#step/sssd/56

Nothing more to do here.

Also available in: Atom PDF