Project

General

Profile

action #50459

[qam][blue][leap] test fails in updates_packagekit_gpk - fail after update

Added by pcervinka over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2019-04-16
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-15.1-DVD-Updates-x86_64-gnome@64bit-2G fails in
updates_packagekit_gpk

Test suite description

Reproducible

Fails since (at least) Build 20190414-1

Expected result

Last good: 20190413-1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by pcervinka over 2 years ago

Needle updates_none is matched https://openqa.opensuse.org/tests/908669#step/updates_packagekit_gpk/28
Window should be closed by pressing ret key, but window is not closed

        if (match_has_tag("updates_none")) {
            send_key 'ret';
            return;
        }

Package updater is still running on background https://openqa.opensuse.org/tests/908669#step/updates_packagekit_gpk/29
https://openqa.opensuse.org/tests/908669#step/updates_packagekit_gpk/30

#2 Updated by pcervinka over 2 years ago

#3 Updated by pcervinka over 2 years ago

  • Status changed from New to In Progress

#4 Updated by pcervinka over 2 years ago

Could be related to "rogue workqueue lockup bsc#1126782" when I clone job to private openQA instance, it works fine.
Soft-failure is reported http://10.100.12.105/tests/1899#step/updates_packagekit_gpk/29, but it doesn't happen on ooo.

#5 Updated by pcervinka over 2 years ago

  • Status changed from In Progress to Feedback

Couldn't reproduce at all on private instance. Today was uploaded latest iso to ooo and tests stopped failing.
OK runs:
https://openqa.opensuse.org/tests/910572#step/updates_packagekit_gpk/1
https://openqa.opensuse.org/tests/910573#step/updates_packagekit_gpk/1

Let's wait for more runs.

#6 Updated by pcervinka over 2 years ago

  • Blocks deleted (action #39449: enable openQA maintenance testing)

#7 Updated by pcervinka over 2 years ago

  • Status changed from Feedback to Resolved

Looks stable now with latest ISO, couldn't reproduce.

Also available in: Atom PDF