Project

General

Profile

action #49610

[sle][migration][sle15sp1] test fails in installation_overview - suspect script change lead this issue

Added by coolgw over 3 years ago. Updated over 3 years ago.

Status:
Rejected
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2019-03-25
Due date:
% Done:

0%

Estimated time:
16.00 h
Difficulty:
medium

Description

Observation

Not happen before, found following commit, maybe related with this issue.
diff --git a/tests/installation/installation_overview.pm b/tests/installation/installation_overview.pm
index 532a12fa3..4de1f1d4f 100644
--- a/tests/installation/installation_overview.pm
+++ b/tests/installation/installation_overview.pm
@@ -15,7 +15,7 @@ use strict;
use warnings;
use base "y2logsstep";
use testapi;
-use version_utils qw(is_caasp is_hyperv_in_gui);
+use version_utils qw(is_caasp is_hyperv is_upgrade);
use Utils::Backends 'is_remote_backend';

@@ -70,12 +70,13 @@ sub run {
assert_screen "inst-xen-pattern" if get_var('XEN');
ensure_ssh_unblocked;
# Check the systemd target, see poo#45020

  • return if (is_caasp || check_var('MACHINE', 'svirt-hyperv'));
  • if (get_var('DESKTOP') && !is_hyperv_in_gui) {
  • # We need to exclude some scenarios where it doesn't work well
  • return if (is_caasp || is_upgrade || is_hyperv);
  • if (get_var('DESKTOP')) { my $target = check_var('DESKTOP', 'textmode') ? "multi-user" : "graphical"; select_console 'install-shell'; # The default.target is not yet linked, so we have to parse the logs.
  • assert_script_run("grep 'target has been set' /var/log/YaST2/y2log |tail -1 |grep \"$target\"", fail_message => "Wrong systemd target detected, aborting");
  • script_run("grep 'target has been set' /var/log/YaST2/y2log |tail -1 |grep --color=auto \"$target\"") && record_info "Could no detect the systemd target. Expected was: $target"; select_console 'installation'; } }

openQA test in scenario sle-15-SP1-Installer-DVD-aarch64-offline_sles12sp4_media_base_all_full@aarch64 fails in
installation_overview

Test suite description

Reproducible

Fails since (at least) Build 121.1

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by leli over 3 years ago

  • Assignee set to leli
  • Estimated time set to 16.00 h
  • Difficulty set to medium

This issue caused by PR# https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/7109 . I already ask for reverting on the PR.

#2 Updated by leli over 3 years ago

  • Status changed from New to Rejected

This failure already fixed by https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/7136. Re-run and no such issue exist. So reject it.

Also available in: Atom PDF