Project

General

Profile

action #49121

[qam][kernel][multipath][aarch64] Qemu fails setup multipath on qemu_aarch64

Added by pcervinka over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Spike/Research
Target version:
-
Start date:
2019-03-12
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

QEMU fails when is MULTIPATH=1 defined on qemu_aarch64.

It incorrectly uses "virtio-blk-device" instead od iscsi:
[2019-03-12T11:33:04.755 UTC] [debug] QEMU: qemu-system-aarch64: -device virtio-blk-device,id=hd0-device-path0,drive=hd0,share-rw=true,bus=scsi0.0,serial=hd0: Device 'virtio-blk-device' can't go on SCSI bus

https://openqa.suse.de/tests/2535429/file/autoinst-log.txt

Same setup works fine on x86_64 and ppc64le.

History

#2 Updated by pcervinka over 2 years ago

HDDMODEL comes from aarch64 machine definition:

HDDMODEL=virtio-blk-device
HDDSIZEGB=20
QEMU=aarch64
QEMUCPU=host
QEMUCPUS=2
QEMUMACHINE=virt,usb=off,gic-version=host
SERIALDEV=ttyAMA0
UEFI=1
UEFI_PFLASH_CODE=/usr/share/qemu/aavmf-aarch64-code.bin
UEFI_PFLASH_VARS=/usr/share/qemu/aavmf-aarch64-vars.bin
VGA=std
WORKER_CLASS=qemu_aarch64

#3 Updated by pcervinka over 2 years ago

Restarted installation with HDDMODEL=scsi-hd and it passed ok.

Restarted kdump test failed with:
[2019-03-13T09:50:50.502 UTC] [debug] QEMU: qemu-system-aarch64: -device scsi-hd,id=hd0-device-path1,drive=hd0-overlay0,share-rw=true,bus=scsi1.0,bootindex=0,serial=hd0: The bootindex 0 has already been used

This was already fixed. openqaworker-arm-2:4 doesn't have updated os-autoinst.

#4 Updated by pcervinka over 2 years ago

  • Status changed from New to In Progress

#5 Updated by pcervinka over 2 years ago

nick confirmed on #testing that there was an issue with update:
"Seems we skipped deployment the last two times due to zypper bailing out. Let me check if we can update aarch only or need to deploy"

#6 Updated by pcervinka over 2 years ago

So setting of HDDMODEL definitely works. But not sure and don't know why it is defined at machine level for aarch64.
Will try to ask more around.

#7 Updated by pcervinka over 2 years ago

All aarch64* machines in osd have HDDMODEL=virtio-blk-device, didn't find why exactly it was set in the past. Solution is to set HDDMODEL=scsi-hd.

#8 Updated by pcervinka over 2 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF