communication #47249

upgrade progress.o.o using latest Redmine and latest Leap 15.0

Added by tuanpembual 10 months ago. Updated 9 months ago.

Status:ClosedStart date:07/02/2019
Priority:NormalDue date:
Assignee:tuanpembual% Done:

0%

Category:-
Target version:-
Duration:

Description

on the research base monthly meeting.
Goal:
- setup the instance using latest leap and latest redmine on a new VM
- test the plugins

as soon as everything is confirmed to be working, switch over the latest db dump and good to go

History

#1 Updated by tuanpembual 10 months ago

I using leap 15.0 on my vm
- redmine 4.0.1 (2019-01-20) from source

I found issue on GEM deps. I failed to install RMagick 2.16.0 because leap 15.0 using ImageMagick-7.0.7.34-lp150.2.21.1.x86_64 with not compatible with RMagick 2.16.0. So I uninstall ImageMagick-7.0.7.34 and install ImageMagick-6.9.10-26 from source. After that, I rerun bundle install.

I run redmine using puma and nginx as proxy from port 3000. All good. For testing, I use postgres as DB. But I am not sure what db we use on progress.o.o. Need more guide.

Next, I need listing plugins we are using on progress.o.o so I can start testing to make sure plugins run well on latest redmine.

Thanks,
Estu

#2 Updated by tuanpembual 10 months ago

  • Private changed from Yes to No

#4 Updated by tampakrap 9 months ago

  • Status changed from New to Closed

I'm closing this one as duplicate of 27720

#5 Updated by tuanpembual 9 months ago

Noted. But I need access to 27720.

Thanks

Also available in: Atom PDF