Project

General

Profile

action #44918

[sle][migration][sle15sp1] test fails in patch_sle - Test died: 'zypper -n in -t pattern ' failed with code 3

Added by coolgw about 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2018-12-10
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-SP1-Installer-DVD-x86_64-offline_sles15_pscc_basesys+srv+wsm_all_full@64bit fails in
patch_sle

Reproducible

Fails since (at least) Build 104.1

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by coolgw about 4 years ago

  • Subject changed from test fails in patch_sle - Test died: 'zypper -n in -t pattern ' failed with code 3 to [sle][migration][sle15sp1] test fails in patch_sle - Test died: 'zypper -n in -t pattern ' failed with code 3

#2 Updated by hjluo about 4 years ago

  • Assignee set to hjluo

#3 Updated by hjluo about 4 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 70

It's now passed in 121.1, 125.1 and 126.1 https://openqa.suse.de/tests/2337066#step/patch_sle/94

#4 Updated by leli about 4 years ago

  • Priority changed from Normal to High

#5 Updated by leli about 4 years ago

reproduced on build 128.1.
https://openqa.suse.de/tests/2341312#

#6 Updated by hjluo about 4 years ago

  • % Done changed from 70 to 80

1) the root cause for the failure is that the zypper -n in -t pattern $pkg got null $pkg.
2) the root cause for got the null $pkg is that the script_run got all the output {STDOUT and STDERR} form tty as STDOUT.
3) solution:
just get the STDOUT from the tty for the script_run.

Z2Aej-0-
_sEDz
32bit apparmor base dhcp_dns_server directory_server documentation enhanced_base file_server fips fonts gateway_server gnome_basic kvm_server kvm_tools lamp_server mail_server ofed oracle_server print_server sap_server sw_management x11 xen_server xen_tools yast2_basis
SCRIPT_FINISHED_sEDz-0-
vyWKW
[ 107.299064] dbus-daemon[717]: [system] Activating via systemd: service name='org.freedesktop.hostname1' unit='dbus-org.freedesktop.hostname1.service' requested by ':1.28' (uid=455 pid=2259 comm="/usr/bin/gnome-shell ")
[ 107.307912] systemd[1]: Starting Hostname Service...
[ 107.333727] dbus-daemon[717]: [system] Successfully activated service 'org.freedesktop.hostname1'
[ 107.337522] systemd[1]: Started Hostname Service.
32bit apparmor base devel_C_C++ devel_java devel_kde devel_kde_frameworks devel_mono devel_osc_build devel_perl devel_python3 devel_qt5 devel_ruby devel_tcl dhcp_dns_server directory_server documentation enhanced_base enlightenment file_server fips fonts games gateway_server gnome_basic haskell_platform kde kvm_server kvm_tools lamp_server lxde lxqt mail_server mate network_admin ofed oracle_server print_server sap_server sw_management x11 xen_server xen_tools xfce yast2_basis
SCRIPT_FINISHEDvyWKW-0-
ddly~-3-
UYVD2-0-

$VAR1 = [
'',
'',
'',
'',
'")
[',
'\':1.28\'',
'\'org.freedesktop.hostname1\'
[',
'(uid=455',
'107.299064]',
'107.307912]',
'107.333727]',
'107.337522]',
'Activating',
'Hostname',
'Hostname',
'Service.
32bit',
'Service...
[',
'Started',
'Starting',
'Successfully',
'[',
'[system]',
'[system]',
'activated',
'by',
'comm="/usr/bin/gnome-shell',
'dbus-daemon[717]:',
'dbus-daemon[717]:',
'devel_C_C++',
'devel_java',
'devel_kde',
'devel_kde_frameworks',
'devel_mono',
'devel_osc_build',
'devel_perl',
'devel_python3',
'devel_qt5',
'devel_ruby',
'devel_tcl',
'enlightenment',
'games',
'haskell_platform',
'kde',
'lxde',
'lxqt',
'mate',
'name=\'org.freedesktop.hostname1\'',
'network_admin',
'pid=2259',
'requested',
'service',
'service',
'systemd:',
'systemd[1]:',
'systemd[1]:',
'unit=\'dbus-org.freedesktop.hostname1.service\'',
'via',
'xfce'
];

#7 Updated by hjluo about 4 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 80 to 100

#8 Updated by hjluo about 4 years ago

the fix has been verified in this run http://openqa-apac1.suse.de/tests/2976

#9 Updated by leli about 4 years ago

  • Status changed from Resolved to In Progress

Still can be reproduced. Reopen the ticket.
https://openqa.suse.de/tests/2352706#step/patch_sle/99

#10 Updated by leli about 4 years ago

  • % Done changed from 100 to 50

#12 Updated by hjluo about 4 years ago

Suggest fix:

  1. we got the output of the script_output
  2. check the line we wanted -i which start with i and -u start with "^ |"
  3. split the package name string to array
  4. sort and unique the array.

#15 Updated by hjluo about 4 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 90 to 100

Also available in: Atom PDF