action #41465

[functional][u] test fails in openqa_webui reproducibly, coredump process or masked packagekit in background at fault?

Added by okurz over 1 year ago. Updated 12 months ago.

Status:RejectedStart date:23/09/2018
Priority:NormalDue date:
Assignee:okurz% Done:

0%

Category:Bugs in existing tests
Target version:QA - future
Difficulty:
Duration:

Description

Observation

openQA test in scenario openqa-Tumbleweed-dev-x86_64-openqa_install+publish@64bit-2G fails in
openqa_webui
and the serial log shows

e8Ea9-0-
[  166.830537] systemd[2086]: Started D-Bus User Message Bus.
[  166.842194] dbus-daemon[2181]: [session uid=0 pid=2181] Activating via systemd: service name='org.gtk.vfs.Daemon' unit='gvfs-daemon.service' requested by ':1.1' (uid=0 pid=2179 comm="/usr/bin/appstream-util uninstall NON_OSS ")
[  166.844931] systemd[2086]: Starting Virtual filesystem service...
[  166.852492] dbus-daemon[2181]: [session uid=0 pid=2181] Successfully activated service 'org.gtk.vfs.Daemon'
[  166.853902] systemd[2086]: Started Virtual filesystem service.
[  166.859675] dbus-daemon[2181]: [session uid=0 pid=2181] Activating via systemd: service name='org.gtk.vfs.Metadata' unit='gvfs-metadata.service' requested by ':1.1' (uid=0 pid=2179 comm="/usr/bin/appstream-util uninstall NON_OSS ")
[  166.862485] systemd[2086]: Starting Virtual filesystem metadata service...
[  166.954915] dbus-daemon[2181]: [session uid=0 pid=2181] Successfully activated service 'org.gtk.vfs.Metadata'
[  166.956481] systemd[2086]: Started Virtual filesystem metadata service.
[  172.183695] dbus-daemon[739]: [system] Activating via systemd: service name='org.freedesktop.PackageKit' unit='packagekit.service' requested by ':1.53' (uid=1000 pid=1926 comm="/usr/bin/gnome-software --gapplication-service ")
[  172.186397] dbus-daemon[739]: [system] Activation via systemd failed for unit 'packagekit.service': Unit packagekit.service is masked.
[  172.196270] gnome-software[1926]: can't reliably fixup error code 36 in domain g-io-error-quark
[  172.197265] gnome-software[1926]: failed to call gs_plugin_refine on packagekit-refine: failed to resolve package_ids: Error calling StartServiceByName for org.freedesktop.PackageKit: GDBus.Error:org.freedesktop.systemd1.UnitMasked: Unit packagekit.service is masked.
[  172.212069] dbus-daemon[739]: [system] Activating via systemd: service name='org.freedesktop.PackageKit' unit='packagekit.service' requested by ':1.53' (uid=1000 pid=1926 comm="/usr/bin/gnome-software --gapplication-service ")
[  172.213674] gnome-software[1926]: can't reliably fixup error code 36 in domain g-io-error-quark
[  172.214510] dbus-daemon[739]: [system] Activation via systemd failed for unit 'packagekit.service': Unit packagekit.service is masked.
[  172.215536] gnome-software[1926]: failed to call gs_plugin_refine on packagekit-refine: failed to resolve package_ids: Error calling StartServiceByName for org.freedesktop.PackageKit: GDBus.Error:org.freedesktop.systemd1.UnitMasked: Unit packagekit.service is masked.
[  172.229655] dbus-daemon[739]: [system] Activating via systemd: service name='org.freedesktop.PackageKit' unit='packagekit.service' requested by ':1.53' (uid=1000 pid=1926 comm="/usr/bin/gnome-software --gapplication-service ")
[  172.231193] gnome-software[1926]: can't reliably fixup error code 36 in domain g-io-error-quark
[  172.245073] dbus-daemon[739]: [system] Activation via systemd failed for unit 'packagekit.service': Unit packagekit.service is masked.
[  172.246130] gnome-software[1926]: failed to call gs_plugin_refine on packagekit-refine: failed to resolve package_ids: Error calling StartServiceByName for org.freedesktop.PackageKit: GDBus.Error:org.freedesktop.systemd1.UnitMasked: Unit packagekit.service is masked.
[  172.247873] dbus-daemon[739]: [system] Activating via systemd: service name='org.freedesktop.PackageKit' unit='packagekit.service' requested by ':1.53' (uid=1000 pid=1926 comm="/usr/bin/gnome-software --gapplication-service ")
[  172.258714] gnome-software[1926]: can't reliably fixup error code 36 in domain g-io-error-quark
[  172.259562] dbus-daemon[739]: [system] Activation via systemd failed for unit 'packagekit.service': Unit packagekit.service is masked.
[  172.272427] gnome-software[1926]: failed to call gs_plugin_refine on packagekit-refine: failed to resolve package_ids: Error calling StartServiceByName for org.freedesktop.PackageKit: GDBus.Error:org.freedesktop.systemd1.UnitMasked: Unit packagekit.service is masked.
[  172.274196] dbus-daemon[739]: [system] Activating via systemd: service name='org.freedesktop.PackageKit' unit='packagekit.service' requested by ':1.53' (uid=1000 pid=1926 comm="/usr/bin/gnome-software --gapplication-service ")
[  172.282411] gnome-software[1926]: hiding category productivity featured applications: found only 0 to show, need at least 9
[  172.283417] dbus-daemon[739]: [system] Activation via systemd failed for unit 'packagekit.service': Unit packagekit.service is masked.
[  172.300387] gnome-software[1926]: hiding category games featured applications: found only 0 to show, need at least 9
[  172.301590] dbus-daemon[739]: [system] Activating via systemd: service name='org.freedesktop.PackageKit' unit='packagekit.service' requested by ':1.53' (uid=1000 pid=1926 comm="/usr/bin/gnome-software --gapplication-service ")
[  172.306945] gnome-software[1926]: failed to get featured apps: no apps to show
[  172.307711] dbus-daemon[739]: [system] Activation via systemd failed for unit 'packagekit.service': Unit packagekit.service is masked.
[  172.318470] gnome-software[1926]: Only 0 apps for recent list, hiding
[  172.319181] dbus-daemon[739]: [system] Activating via systemd: service name='org.freedesktop.PackageKit' unit='packagekit.service' requested by ':1.53' (uid=1000 pid=1926 comm="/usr/bin/gnome-software --gapplication-service ")
[  172.325448] gnome-software[1926]: can't reliably fixup error code 36 in domain g-io-error-quark
[  172.326282] dbus-daemon[739]: [system] Activation via systemd failed for unit 'packagekit.service': Unit packagekit.service is masked.
[  172.327313] gnome-software[1926]: failed to call gs_plugin_refine on packagekit-refine: failed to resolve package_ids: Error calling StartServiceByName for org.freedesktop.PackageKit: GDBus.Error:org.freedesktop.systemd1.UnitMasked: Unit packagekit.service is masked.
[  172.331628] gnome-software[1926]: Only 0 apps for popular list, hiding
[  172.332388] gnome-software[1926]: can't reliably fixup error code 36 in domain g-io-error-quark
[  172.333222] gnome-software[1926]: failed to call gs_plugin_refine on packagekit-refine: failed to resolve package_ids: Error calling StartServiceByName for org.freedesktop.PackageKit: GDBus.Error:org.freedesktop.systemd1.UnitMasked: Unit packagekit.service is masked.
[  172.334965] gnome-software[1926]: failed to call gs_plugin_refine on packagekit-history: Failed to get history: GDBus.Error:org.freedesktop.systemd1.UnitMasked: Unit packagekit.service is masked.
[  174.610169] traps: appstreamcli[2225] trap int3 ip:7fde87f5dc75 sp:7ffd05939a50 error:0 in libglib-2.0.so.0.5600.2[7fde87f26000+7b000]
[  175.428256] systemd[1]: Started Process Core Dump (PID 2228/UID 0).
[  177.966601] systemd-coredump[2229]: Process 2225 (appstreamcli) of user 0 dumped core.
[  190.821997] chronyd[731]: Selected source 129.70.132.33
[  327.942218] chronyd[731]: Selected source 131.188.3.221
yU7DU-127-

where I can see a lot of error output regarding the packagekit service we just masked as well as appstreamcli core dumping https://bugzilla.suse.com/show_bug.cgi?id=1105691

Reproducible

Fails since (at least) Build :TW.1744

Expected result

Last good: :TW.1743 (or more recent)

Suggestions

Find out if the appstreamcli core dump handling or maybe packagekit masking produce the problem or maybe something else, e.g. simply just sleep the test for a long time after the mask packagekit-call

Further details

Always latest result in this scenario: latest

History

#1 Updated by okurz about 1 year ago

  • Target version changed from Milestone 20 to future

#2 Updated by okurz 12 months ago

  • Status changed from New to Rejected
  • Assignee set to okurz

Also available in: Atom PDF