Project

General

Profile

action #38531

[tw][desktop] test fails in sshd

Added by yuanren10 about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Bugs in existing tests
Target version:
-
Start date:
2018-07-18
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-extra_tests_in_textmode@64bit fails in
sshd

Description

I migrate "console_setup" from "extra_test_on_" to the "create_hdd_" in order to setup in advance and don't have to test on extra_test_on_* every time. Please ref: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/5387
By the way, I delete the "x11/x11_setup" from "extra_test_on_*", because the "console_setup" had done all the stuff in "x11/x11_setup".
However, I got some problems. After "console_setup", the /dev/ttyS0 would belongs to the tty group, and also changed the bernhard's group to tty group. When I use this created qcow2 to reboot the system, the bernhard's group still belongs to tty but /dev/ttyS0 belongs to the dialout group. It caused the permission denied when echo something to the /dev/ttyS0. For example in this case.
There is a same problem happened in "window_system" case when I working on poo#23884(https://progress.opensuse.org/issues/23884). You can also take look into my test run: http://10.67.19.67/tests/344#

This problem only happened in Tumbleweed. Please compare with the SLE(They do the same job):
qam-regression-installation: http://openqa.suse.de/tests/1836147
qam-regression-other: http://openqa.suse.de/tests/1836152

Workaround

After reboot to the desktop first time, and then run the x11/x11_setup case to make sure /dev/ttyS0 and bernhard belongs to the same group.


Related issues

Related to openQA Tests - action #37027: [tw][desktop] Update create_hdd_* to make sure right permissionsResolved2018-06-11

History

#1 Updated by yuanren10 about 3 years ago

  • Status changed from New to In Progress

What I found:

I notice when I use "x11/x11_setup" replace "console_setup" in create_hdd_tess_on_*, all tests mentioned above passed. So, I look into what's changed in console_setup. There two commands run: systemctl --no-pager mask serial-gettty@ttyS0 and systemctl --no-pager stop serial-gettty@ttyS0. Before run these two commands, ttyS0 belongs to the tty group. But after stop serial-gettty@ttyS0 and run the systemctl mask, ttyS0 would stay in dialout group after reboot. That's the reason caused permission denied.

Workaround

Firstly, "console_setup" cannot be replaced by "x11/x11_setup", Because it would cause the "extra_test_on_kde" wrong(we had discussed). After reference poo#30613, I think we should also add bernhard user into the dialout group in force in "ensure_serialdev_permissions" function.

#2 Updated by okurz about 3 years ago

  • Related to action #37027: [tw][desktop] Update create_hdd_* to make sure right permissions added

#3 Updated by okurz about 3 years ago

  • Subject changed from test fails in sshd to [tw][desktop] test fails in sshd

#4 Updated by yuanren10 about 3 years ago

Could you please check the pr#5438. I think this poo can close.

#5 Updated by yuanren10 about 3 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF