Project

General

Profile

action #34465

[sle][migration][sle15] test fails in patch_before_migration -- wait some time to uncheck scc-beta-filter-checkbox

Added by leli over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2018-04-08
Due date:
% Done:

100%

Estimated time:
Difficulty:
Duration:

Description

Observation

openQA test in scenario sle-15-Installer-DVD-ppc64le-media_upgrade_sles12sp3+ha+sdk_allpatterns@ppc64le fails in
patch_before_migration

Reproducible

Fails since (at least) Build 550.2 (current job)

Expected result

Last good: 547.1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by leli over 2 years ago

  • Subject changed from test fails in patch_before_migration -- scc-module-ha not be selected may for the 'spc' key sent twice to [sle][migration][sle15] test fails in patch_before_migration -- scc-module-ha not be selected may for the 'spc' key sent twice

#2 Updated by qmsu over 2 years ago

  • Subject changed from [sle][migration][sle15] test fails in patch_before_migration -- scc-module-ha not be selected may for the 'spc' key sent twice to [sle][migration][sle15] test fails in patch_before_migration -- HA isn't selected by the 'spc' key (next key sent too fast?)

#3 Updated by qmsu over 2 years ago

  • Assignee set to qmsu

#4 Updated by qmsu over 2 years ago

  • Subject changed from [sle][migration][sle15] test fails in patch_before_migration -- HA isn't selected by the 'spc' key (next key sent too fast?) to [sle][migration][sle15] test fails in patch_before_migration -- wait some time to uncheck scc-beta-filter-checkbox

The issue is on code bellow:

        if (get_var('SCC_ADDONS')) {
            if (check_screen('scc-beta-filter-checkbox', 5)) {
                if (get_var('SP3ORLATER')) {
                    send_key 'alt-i';    # uncheck 'Hide Beta Versions'
                }
                else {
                    send_key 'alt-f';    # uncheck 'Filter Out Beta Version'
                }
            }

we need some time to make sure 'Hide Beta Versions' unchecked before going forward, otherwise it will cause problem like this failure: we thought scc-module-area-selected area is activated but send_key 'alt-i'; brings the cursor back to scc-beta-filter-checkbox area.

#6 Updated by qmsu over 2 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 60

#7 Updated by qmsu over 2 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 60 to 100

Verified with latest build, such as test run for ppc64le:
https://openqa.suse.de/tests/1647279#step/patch_sle/26

Also available in: Atom PDF