Project

General

Profile

action #33118

[sle][migration][sle15] test fails in reboot_to_upgrade - Test died: Machine didn't shut down! at /var/lib/openqa/cache/tests/sle/lib/utils.pm line 442.

Added by dehai over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
Bugs in existing tests
Start date:
2018-03-13
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-Installer-DVD-s390x-media_upgrade_sles12sp3+ha+sdk_allpatterns_ADDONURL@s390x-kvm-sle12 fails in
reboot_to_upgrade

Reproducible

Fails since (at least) Build 499.1

Further details

Always latest result in this scenario: latest

Affect

All s390x suse kvm upgrade test cases.

History

#2 Updated by mgriessmeier over 3 years ago

the test has set DESKTOP=gnome but in reboot_to_upgrade:31 you do a power_action('reboot', textmode => 1); - this looks wrong to me.

It is a new test right? did it run before on zkvm?

#3 Updated by dehai over 3 years ago

mgriessmeier wrote:

the test has set DESKTOP=gnome but in reboot_to_upgrade:31 you do a power_action('reboot', textmode => 1); - this looks wrong to me.

It is a new test right? did it run before on zkvm?

Hi Matthias:
It is not new test case, just modify those test suits' name and some parameters, so there is no history result. it always have DESKTOP=gnome, I don't change it.

#4 Updated by mgriessmeier over 3 years ago

dehai wrote:

mgriessmeier wrote:

the test has set DESKTOP=gnome but in reboot_to_upgrade:31 you do a power_action('reboot', textmode => 1); - this looks wrong to me.

It is a new test right? did it run before on zkvm?

Hi Matthias:
It is not new test case, just modify those test suits' name and some parameters, so there is no history result. it always have DESKTOP=gnome, I don't change it.

so it seems that VERSION variable was switched from 15 (last good) to 12-SP3
but I don't get it why this should be the reason for that fail :(
sorry, nevermind, different testsuite - what was the old name of the testsuite?

I mean... I've changed something in this 'reboot' code recently, but it's in a different code path as far as I can see... so I don't see the relation to be honest

#5 Updated by mgriessmeier over 3 years ago

  • Status changed from New to In Progress
  • Assignee set to mgriessmeier
  • Target version set to Milestone 15

I will try to find out if my changes are causing this

#6 Updated by dehai over 3 years ago

sorry, nevermind, different testsuite - what was the old name of the testsuite?

Hi Matthias:
Here is the old name and link:
media_upgrade_sles12sp3+ha+sdk_allpatterns_workaround_modules
https://openqa.suse.de/tests/1532162

#7 Updated by qmsu over 3 years ago

Hello Matthias:

Regarding to this issue, maybe we can fix it with following changes to reboot_to_upgrade.pm

diff --git a/tests/migration/reboot_to_upgrade.pm b/tests/migration/reboot_to_upgrade.pm
index 09462592..41dfb7e9 100644
--- a/tests/migration/reboot_to_upgrade.pm
+++ b/tests/migration/reboot_to_upgrade.pm
@@ -28,7 +28,8 @@ sub run {

     # Reboot from Installer media for upgrade
     set_var('BOOT_HDD_IMAGE', 0) if get_var('UPGRADE') || get_var('AUTOUPGRADE');
-    power_action('reboot', textmode => 1);
+    assert_script_run "sync", 300;
+    type_string "reboot --force\n";
 }

Because in this case "assert_shutdown_and_restore_system" is not really required, which is used to re-connect VNC session, afterwards bootloader_zkvm module will make it work. I have verified the changes above works for s390x zkvm (should also work for s390x suse kvm):
http://openqa-apac1.suse.de/tests/440#step/welcome/4

#8 Updated by qmsu over 3 years ago

Would you please help review PR for fixing this issue:
https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/4597

#9 Updated by mgriessmeier over 3 years ago

qmsu wrote:

Would you please help review PR for fixing this issue:
https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/4597

commented on PR

#10 Updated by qmsu over 3 years ago

Hi Matthias:

Your changes for reboot code should be fine, and seems the only problem here during upgrade is that we shouldn't use power_action('reboot') in reboot_to_upgrade, see my comment in
https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/4597

#11 Updated by mgriessmeier over 3 years ago

PR merged

#12 Updated by mgriessmeier over 3 years ago

  • Status changed from In Progress to Resolved

the issue described in this ticket is now fixed on o.s.d -> https://openqa.suse.de/tests/1546343
thanks qmsu for your contribution

Also available in: Atom PDF