Project

General

Profile

action #32842

[sle][migration][sle15] test fails in deregister - inadaptable test module on un-registered system

Added by qmsu over 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2018-03-07
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-Installer-DVD-ppc64le-media_upgrade_sles12sp3+alladdons_allpatterns_ppc64le@ppc64le fails in
deregister

Reproducible

Fails since (at least) Build 456.1

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by dehai over 3 years ago

  • Assignee set to dehai

quickly investigate:

media upgrade will keep unregistered state. don't need involve this test module

solution:

modify main_common.pm

1038     if (check_var_array('SCC_ADDONS', 'tcm') && get_var('PATTERNS') && sle_version_at_least('12-SP3')) {
1039         loadtest "feature/feature_console/deregister";
1040     }

to

1038     if (check_var_array('SCC_ADDONS', 'tcm') && get_var('PATTERNS') && sle_version_at_least('12-SP3') && !get_var("MEDIA_UPGRADE")) {
1039         loadtest "feature/feature_console/deregister";
1040     }

#2 Updated by qmsu over 3 years ago

dehai: Please think about another way to fix this issue, because we can run media upgrade even on a registered system.

#3 Updated by okurz over 3 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: media_upgrade_sles12sp3+alladdons_allpatterns_ppc64le
https://openqa.suse.de/tests/1624819

#4 Updated by dehai over 3 years ago

  • Status changed from New to In Progress

#6 Updated by dehai about 3 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF