Project

General

Profile

action #31657

[qam] test fails in runc - conflict between docker-runc and runc

Added by pcervinka almost 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2018-02-12
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP2-Server-DVD-Updates-x86_64-mau-extratests@64bit fails in
runc

Reproducible

Fails since (at least) Build 20180208-1

Expected result

Last good: 20180207-2 (or more recent)

Further details

Always latest result in this scenario: latest

History

#2 Updated by pgeorgiadis almost 4 years ago

  • % Done changed from 0 to 50

thanks for pointing that. I see that we now have docker-runc and runc in SLES 12 SP2, SP3 and SLE15. As for kubic and Micros this is now called docker-runc-kubic.

Please mind that 'docker-runc' and 'runc' are two different packages, which come with two different binaries: '/usr/bin/docker-runc' and '/usr/bin/runc' respectively.
As a result the fix will be to replace the current runc test with a docker-runc test.
After that, I will write a new runc test based on OCI (umoci, skopeo) rather than relying on docker.

#3 Updated by pgeorgiadis almost 4 years ago

  • % Done changed from 50 to 100

#4 Updated by pgeorgiadis almost 4 years ago

  • Status changed from New to In Progress

Merged/ In case of problems, please re-open.

#5 Updated by pgeorgiadis almost 4 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF