Project

General

Profile

action #31519

[microos] Update repository is ready in transactional-update test on kubic

Added by mkravec over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2018-02-08
Due date:
% Done:

20%

Estimated time:
Difficulty:

Description

First update test is skipped on Kubic.
Second one testing that there are no updates is not skipped, and fails (there are update repos in kubic now).

Observation

openQA test in scenario kubic-Tumbleweed-DVD-x86_64-MicroOS-worker-oci-textmode@64bit fails in
transactional_update

Reproducible

Fails since (at least) Build 20180110

Expected result

Last good: 20180109 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by mkravec over 3 years ago

  • % Done changed from 0 to 20

Broken section in kubic is not broken. I will skip this test until it's fixed.

#cat /etc/YaST2/build
openSUSE-Tumbleweed-Kubic-DVD-x86_64-Build0002

#https://build.opensuse.org/package/view_file/openSUSE:Factory:Update/update-test-trivial/update-test-trivial.spec?expand=1

%pre -n update-test-broken
if [ $1 -ne 1 ]; then
    if [[ "$(cat /etc/YaST2/build)" == *"SUSE-CaaS-Platform-"* ]]; then
        sed -i -e 's,foo\t,bar\t,g' /some/none/existing/file
    fi

#3 Updated by mkravec over 3 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF