Project

General

Profile

action #31393

[CaaSP] Make sure kubeconfig is downloaded before tests continue

Added by mkravec over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2018-02-06
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Kubeconfig download sometimes takes longer. Make sure it's downloaded before we continue.

  • modify controller to wait for download confirmation
  • modify test to fail if kubeconfig does not exist

Observation

openQA test in scenario caasp-2.0-CaaSP-DVD-Incidents-x86_64-QAM-CaaSP-controller@qam-caasp_x86_64 fails in
stack_kubernetes

Reproducible

Fails since (at least) Build :6038:rpm.1517313724

Expected result

Last good: :5753:bash.1517312902 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by mkravec over 3 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF