Project

General

Profile

action #31180

[qam] test fails in kernel_kexec - migration to systemctl broke the test

Added by pcervinka almost 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2018-02-01
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP2-Server-DVD-Updates-x86_64-mau-qa_kernel_kexec@64bit fails in
kernel_kexec

Reproducible

Fails since (at least) Build 20180123-4

Expected result

Last good: 20180123-3 (or more recent)

Further details

Always latest result in this scenario: latest

Recent migration to systemctl function broke behavior of the test:
https://github.com/os-autoinst/os-autoinst-distri-opensuse/commit/21fff9096f3445cf46ebaf2fa33ed88dad12fa59#diff-39dea55692daea7626c926980965f40b

  • type_string("systemctl kexec\n"); -
  • systemctl 'kexec';

Systemctl proceeds correctly with kexec - system is rebooted - but function will timeout (because of reboot).

Test died: command ' systemctl --no-pager kexec' timed out at /var/lib/openqa/cache/tests/sle/lib/utils.pm line 139.

History

#1 Updated by pcervinka almost 4 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF