Project

General

Profile

action #30814

[qam] test fails in yast2_ntpclient - log window is not closed

Added by pcervinka almost 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2018-01-25
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP3-Server-DVD-Incidents-HA-x86_64-qam-ha-alpha-node02@64bit fails in
yast2_ntpclient

Reproducible

Fails since (at least) Build :4389:dhcp.1516271336

Expected result

Last good: :test-1 (or more recent)

Further details

Always latest result in this scenario: latest

There is already wait_still_screen, but for some reason 'alt-c' didn't close log window.
Also needle yast2_ntp-client_configuration is matched even with log window opened.

assert_screen 'yast2_ntp-client_display_log';
wait_still_screen 1;
send_key 'alt-c';

assert that we are back to configuration page

assert_screen 'yast2_ntp-client_configuration';

Code around close window should be more robust.
yast2_ntp-client_configuration needle should be redesigned.

History

#1 Updated by pcervinka almost 4 years ago

  • Assignee set to pcervinka

#2 Updated by pcervinka almost 4 years ago

  • Status changed from New to In Progress

#3 Updated by pcervinka almost 4 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF