Project

General

Profile

action #30216

[sles][virtualization][xen] svirt-xen-hvm tests are incomplete with "DIE The console isn't responding correctly. Maybe half-open socket?"

Added by mgriessmeier about 5 years ago. Updated about 5 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2018-01-12
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-Installer-DVD-x86_64-create_hdd_gnome@svirt-xen-hvm fails in
bootloader

Tests fail as incomplete during bootup with error message
"DIE The console isn't responding correctly. Maybe half-open socket? at /usr/lib/os-autoinst/backend/baseclass.pm line 238."

Reproducible

Fails since (at least) Build 410.1

Expected result

Last good: 409.1 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Project - action #31543: [sles][functional][tools][s390x][ipmi][hard][sporadic] test incompletes - "DIE The console isn't responding correctly. Maybe half-open socket?"Resolved2018-02-082018-03-13

History

#1 Updated by michalnowak about 5 years ago

  • Assignee changed from michalnowak to dasantiago

I noticed three examples of this, all xen-hvm, kernel was booting at that time.

It's recent David's code involved. He should be able to have a look.

#2 Updated by dasantiago about 5 years ago

michalnowak wrote:

I noticed three examples of this, all xen-hvm, kernel was booting at that time.

It's recent David's code involved. He should be able to have a look.

I just cloned the test to my local machine and ran it 5 times. All the 5 times it passed the boot:

http://tragicbox.suse.cz/tests/276
http://tragicbox.suse.cz/tests/277
http://tragicbox.suse.cz/tests/278
http://tragicbox.suse.cz/tests/279
http://tragicbox.suse.cz/tests/280

One strange thing is that it failed after it wrote all the boot options... Can it be a VNC issue?

#3 Updated by dasantiago about 5 years ago

This is failing after a while of starting the udev service.

It seems to be limit issues, for some reason either the XEN machine is slow or is under load.

#4 Updated by dasantiago about 5 years ago

dasantiago wrote:

This is failing after a while of starting the udev service.

It seems to be limit issues, for some reason either the XEN machine is slow or is under load.

https://github.com/os-autoinst/os-autoinst/pull/906/files

#5 Updated by dasantiago about 5 years ago

dasantiago wrote:

dasantiago wrote:

This is failing after a while of starting the udev service.

It seems to be limit issues, for some reason either the XEN machine is slow or is under load.

https://github.com/os-autoinst/os-autoinst/pull/906/files

Patch applied. Working now:
https://openqa.suse.de/tests/1394398

#6 Updated by dasantiago about 5 years ago

  • Status changed from New to In Progress

#7 Updated by dasantiago about 5 years ago

  • Status changed from In Progress to Resolved

#8 Updated by mgriessmeier almost 5 years ago

  • Related to action #31543: [sles][functional][tools][s390x][ipmi][hard][sporadic] test incompletes - "DIE The console isn't responding correctly. Maybe half-open socket?" added

Also available in: Atom PDF