Project

General

Profile

action #28627

[QAM] test fails in apache_ssl

Added by dasantiago almost 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
michalnowak
Category:
Bugs in existing tests
Target version:
-
Start date:
2017-11-30
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP1-Server-DVD-Updates-x86_64-qam-textmode@64bit fails in
apache_ssl

Starting today, all the apache_ssl tests are failing.

By comparing the output of a successfull command:

A failing one:

$ gensslcert -n $(hostname) -e webmaster@$(hostname):
hostname: Name or service no known
comment mod_ssl server certificate
name
C XY
ST unknown
L unknown
U web server
O SUSE Linux Web Server
CN susetest
email webmaster@susetest
srvdays 730
CAdays 2190

An old and successfull one:

$ gensslcert -n $(hostname) -e webmaster@$(hostname):
hostname: Name or service no known
comment mod_ssl server certificate
name susetest-
C XY
ST unknown
L unknown
U web server
O SUSE Linux Web Server
CN susetest
email webmaster@susetest
srvdays 730
CAdays 2190

It seems that the variable name isn't being set. This will then create the certicates as "/etc/apache2/ssl.crt/ca.crt" while we are looking for "/etc/apache2/ssl.crt/-ca.crt". To overcome this we need the -C parameter.

Reproducible

Fails since (at least) Build 20171129-2

Expected result

Last good: 20171129-1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by okurz almost 4 years ago

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/3957 changed the behaviour two days ago. https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/3957#issuecomment-347816779 by mimi1vx states that it should be fine. Maybe the change by maintenance update is not in yet?

#2 Updated by michalnowak almost 4 years ago

  • Status changed from New to Feedback
  • Assignee set to michalnowak

#3 Updated by michalnowak almost 4 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF