Project

General

Profile

action #26030

[kernel] parted return unexpected error in openQA

Added by yosun almost 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2017-10-13
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

xfstests in testing Build301.2
https://openqa.suse.de/tests/1211375#step/xfstests_prepare_env/1

parted return unexpected Error:
In my test machine (expected): (In Alpha5)
ph019:~ # parted -l -m 2>&1 ; echo HTpAF-$?- > /dev/ttyS0
BYT;
/dev/sda:250GB:scsi:512:512:msdos:ATA ST3250620NS:;
1:1049kB:2155MB:2154MB:linux-swap(v1)::type=82;
2:2155MB:55.8GB:53.7GB:btrfs::type=83;
3:55.8GB:98.8GB:42.9GB:btrfs::boot, type=83;
4:218GB:250GB:32.2GB:::lba, type=0f;
6:218GB:231GB:12.9GB:xfs::type=83;
5:231GB:244GB:13.2GB:::type=83;

In openqa (not expected): (Build301.2)

parted -l -m 2>&1 ; echo HTpAF-$?- > /dev/ttyS0

Error: Can't have a partition outside the disk!
Ignore/Cancel?

Need to find out if it's a script issue or product issue. It block xfstests test, if it's a script issue find a workaround.

History

#1 Updated by yosun almost 4 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Resolved by PR
https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/3772

The problem is parted usage changes, this PR is to fix this change.

- Change "parted -l -m" to "parted --script --machine"
- rm create extended partition, and create logical partition directly.

The issue before this change: https://openqa.suse.de/tests/1226919#step/xfstests_prepare_env/1
PR test link: http://10.67.133.102/tests/31#

Also available in: Atom PDF