Project

General

Profile

action #25690

[QAM] test fails in firefox_rss - Site now requires consent to cookies

Added by vsvecova almost 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2017-09-29
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP2-Desktop-DVD-Updates-x86_64-qam-regression-firefox@64bit fails in
firefox_rss

linux.slashdot.org, which is used in this test, now requires the user to agree to the use of cookies.
I am no lawyer, but as I could not reproduce this on my Prague-located OpenQA instance, I assume this could be related to specific German law requirements.

Reproducible

Fails since (at least) Build 20170609-3

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by vsvecova almost 5 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 90

PR: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/3673

Verification run:
SLE12 SP2: http://dreamyhamster.suse.cz/tests/800#step/firefox_rss/21
SLE12 SP3: http://dreamyhamster.suse.cz/tests/799#step/firefox_rss/21

Needles: Created directly via OpenQA needle editor:
https://gitlab.suse.de/openqa/os-autoinst-needles-sles/commit/18b71b27cb96141fbd5a4b661bc04d6db1cd582d
https://gitlab.suse.de/openqa/os-autoinst-needles-sles/commit/6bf15365a2cbeecdcbab0662578a18442cd8f7eb

Note: The cookie dialog appears to be geographically dependent and does not appear when accessing the site from the Prague location, therefore it has not been possible to reproduce this behavior on a CZ-based machine.

#2 Updated by vsvecova almost 5 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 90 to 100

Also available in: Atom PDF