Project

General

Profile

action #21046

[qam] test fails in tracker_search_in_nautilus - keyboard press is not reaching target

Added by pcervinka about 4 years ago. Updated about 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Bugs in existing tests
Target version:
-
Start date:
2017-08-03
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP2-Desktop-DVD-Updates-x86_64-qam-regression-other@64bit fails in
tracker_search_in_nautilus

Reproducible

Fails since (at least) Build 20170801-1

Expected result

Last good: 20170731-1 (or more recent)

Further details

Always latest result in this scenario: latest

CTRL-F should be sent to "nautilus", followed by search string "newfile" and "ret", but
nothing reach application and gedit doesn't start.

09:24:56.1817 39240 <<< testapi::wait_screen_change(timeout=10)
09:24:56.1823 Debug: /var/lib/openqa/cache/tests/sle/tests/x11regressions/tracker/tracker_search_in_nautilus.pm:20 called testapi::send_key
09:24:56.1823 39240 <<< testapi::send_key(key='ctrl-f')
09:24:56.3931 39240 waiting for screen change: 0 1000000
09:24:56.8968 39240 waiting for screen change: 0 20.8163729787519
09:24:56.8969 39240 >>> testapi::wait_screen_change: screen change seen at 0
09:24:56.8970 Debug: /var/lib/openqa/cache/tests/sle/tests/x11regressions/tracker/tracker_search_in_nautilus.pm:21 called testapi::type_string
09:24:56.8971 39240 <<< testapi::type_string(string='newfile', max_interval=250, wait_screen_changes=0)
09:24:57.0686 Debug: /var/lib/openqa/cache/tests/sle/tests/x11regressions/tracker/tracker_search_in_nautilus.pm:22 called testapi::send_key
09:24:57.0688 39240 <<< testapi::send_key(key='ret')
09:24:57.2739 Debug: /var/lib/openqa/cache/tests/sle/tests/x11regressions/tracker/tracker_search_in_nautilus.pm:23 called testapi::assert_screen
09:24:57.2740 39240 <<< testapi::assert_screen(mustmatch='gedit-launched', timeout=3)
09:24:57.2870 39242 MATCH(gedit-launched-20160713:0.00)
09:24:57.3003 39242 MATCH(gedit-launched-20150512:0.0

History

#1 Updated by pcervinka about 4 years ago

  • Status changed from New to Rejected

Duplicated poo because of network issues during poo submission. It continues in #21048.

Also available in: Atom PDF