Project

General

Profile

action #20782

[qam] test fails in install_patterns - mariadb test tries to install devel packages

Added by pcervinka about 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2017-07-26
Due date:
% Done:

90%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP1-Server-DVD-Incidents-x86_64-qam-minimal-full@64bit fails in
install_patterns

Reproducible

Fails since (at least) Build :5248:mariadb.1501012930

Expected result

Last good: :5146:ucode-intel.1500584228 (or more recent)

Further details

Always latest result in this scenario: latest

Devel packages are in SDK and test shouldn't install them.

History

#1 Updated by pcervinka about 4 years ago

  • Status changed from New to In Progress
  • Assignee set to pcervinka

#2 Updated by pcervinka about 4 years ago

install_patterns.pm:

  • if (my ($package) = $line =~ $pattern and $line !~ "xen-tools-domU") {
  • if (my ($package) = $line =~ $pattern and $line !~ "xen-tools-domU" and $line !~ "-devel") {

verified:
http://10.100.12.105/tests/1186#step/install_patterns/1

pull request:
https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/3362

#3 Updated by pcervinka about 4 years ago

  • % Done changed from 0 to 90

#4 Updated by pcervinka about 4 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF