Project

General

Profile

action #19934

[qam] test fails in firefox_smoke - changes in the firefox UI, needles need updating

Added by vsvecova about 5 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2017-06-20
Due date:
% Done:

40%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP2-Desktop-DVD-Updates-x86_64-qam-regression-firefox@64bit fails in
firefox_smoke

Apparently, Firefox changed the default behavior upon first launch and now opens with just one default tab.

Reproducible

Fails since (at least) Build 20170620-1

Expected result

Last good: 20170619-7 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Has duplicate openQA Tests - action #19926: [qam] test fails in firefox - new tutorial window covering the matching areaResolved2017-09-20

History

#1 Updated by vsvecova about 5 years ago

  • Subject changed from [qam] test fails in firefox_smoke - firefox now omits one of the default launch tabs to [qam] test fails in firefox_smoke - changes in the firefox UI, needles need updating
  • Status changed from New to In Progress
  • Assignee set to vsvecova
  • % Done changed from 0 to 40

I started working on this one as I thought it would be a quick fix, but turns out there are some more changes further along.

A couple of the failing needles were updated so far:
https://gitlab.suse.de/openqa/os-autoinst-needles-sles/commit/296c1b1422e9870acd1beda86e8301ff371c535a
https://gitlab.suse.de/openqa/os-autoinst-needles-sles/commit/8f13241c0d4ed72d464450136ab3d9ad214a66d9
https://gitlab.suse.de/openqa/os-autoinst-needles-sles/commit/a2174d9a41f918e7f5aab79eb6ecfaaff27ad889

Will continue fixing this.

#2 Updated by vsvecova about 5 years ago

  • Has duplicate action #19926: [qam] test fails in firefox - new tutorial window covering the matching area added

#3 Updated by vsvecova about 5 years ago

  • Status changed from In Progress to Closed

Closing this one as duplicate, since the issue turns out to be related to poo#19926

Also available in: Atom PDF