Project

General

Profile

action #19434

[sles][functional] test fails in boot_encrypt - Missing keys typing the password in the 'plymouth special dialog'

Added by SLindoMansilla almost 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Category:
Bugs in existing tests
Start date:
2017-05-30
Due date:
% Done:

0%

Estimated time:
Difficulty:
Duration:

Description

Observation

openQA test in scenario sle-12-SP3-Server-DVD-aarch64-cryptlvm@aarch64 fails in
boot_encrypt

Missing keys typing the password in the 'plymouth special dialog'

Reproducible

Fails sporadically since (at least) Build 0405 (current job)

Expected result

Last good: 0402 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by SLindoMansilla almost 3 years ago

  • Status changed from New to In Progress

Related: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/2917
This PR helped to catch this issue.

#2 Updated by SLindoMansilla almost 3 years ago

That could be related. Same build but different arch (ppc64le)

osd#966603#step/grub_test/3



And the changes had to be reverted because the function was also used by another modules causing false positives on them
gh#os-autoinst-distri-opensuse/2984

It is necesary to work on a solution that only affects the module "boot_encrypt"

#4 Updated by SLindoMansilla almost 3 years ago

PR merged gh#os-autoinst-distri-opensuse/2998.
Waiting for verification run on OSD.

#5 Updated by SLindoMansilla almost 3 years ago

  • Status changed from In Progress to Resolved

Failure not seen anymore in the last 10 builds.
The test works properly. If the issue with the missing keys appears again, the type speed should be slow down for aarch64.

https://openqa.suse.de/tests/latest?limit_previous=10&version=12-SP3&machine=aarch64&arch=aarch64&distri=sle&test=cryptlvm&flavor=Server-DVD#previous

Also available in: Atom PDF