Project

General

Profile

action #18968

test fails in patch_and_reboot

Added by dasantiago over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2017-05-05
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP2-Server-DVD-Updates-x86_64-mau-qa_acceptance_fs_stress@64bit fails in
patch_and_reboot

99% of all the "mau" tests are in incomplete status.

The problem seems to be here: https://openqa.suse.de/tests/917773/modules/patch_and_reboot/steps/1/src
on the call $self->system_login() which seems to be raising exception that appears in the logs:

`23:18:57.6656 1259 <<< testapi::send_key(key='esc')
DIE Virtio terminal does not support send_key. Use type_string (possibly with an
ANSI/XTERM escape sequence), or switch to a console which sends key presses, not
terminal codes.
at /usr/lib/os-autoinst/backend/baseclass.pm line 521.

at /usr/lib/os-autoinst/backend/baseclass.pm line 73.`

Reproducible

Fails since (at least) Build 20170505-1 (current job)

Expected result

Last good: 20170504-1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by osukup over 4 years ago

  • Assignee set to osukup
  • Priority changed from Normal to High

#2 Updated by rpalethorpe over 4 years ago

When using virtio_console, one needs to do select_console('root-console') before a reboot because grub does not use the serial console (for now atleast). See kernel/install_ltp.pm (https://openqa.suse.de/tests/918355/modules/install_ltp/steps/1/src).

#3 Updated by osukup over 4 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 100

#4 Updated by osukup over 4 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF