Project

General

Profile

action #16286

action #14068: [tools] Gather more system information and logs in case of boot/reboot times out

online_migration_setup should use same emergency handling as first_boot

Added by okurz over 5 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
michalnowak
Category:
Enhancement to existing tests
Start date:
2017-01-27
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP3-Server-DVD-x86_64-om_proxyscc_sles12sp2_full_update_by_yast@64bit fails in
online_migration_setup
to login to the system.

Reproducible

Fails since (at least) Build 0220 (current job)

Expected result

Last good: 0219 (or more recent)

Suggestion

To investigate the cause the same approach as in first_boot regarding emergency_mode or emergency_shell could be used to find out where and why it failed.

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #15170: boot_to_desktop should use same error analysis approach as first_bootResolved2016-11-30

History

#1 Updated by michalnowak over 5 years ago

  • Status changed from New to In Progress
  • Assignee set to michalnowak

Will move handle_emergency() from first_boot.pm to a place where others can use it as needed.

#2 Updated by michalnowak over 5 years ago

  • Status changed from In Progress to Feedback

This https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/2386 should help analyze the problem, though what makes the system go in emergency mode in the first place has to be elsewhere.

#3 Updated by michalnowak over 5 years ago

  • Status changed from Feedback to Resolved

#4 Updated by okurz over 5 years ago

  • Related to action #15170: boot_to_desktop should use same error analysis approach as first_boot added

Also available in: Atom PDF