Project

General

Profile

Actions

action #154951

closed

coordination #152771: [epic] Add migrations in maintenance

Provide migration from SLES 12 SP5 to SLES 15 SP6 in aggregated updates

Added by JERiveraMoya 6 months ago. Updated 18 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
Start date:
2022-07-15
Due date:
% Done:

0%

Estimated time:

Description

Motivation

See #152771.
Provide migration from SLES 12 SP5 (with released maintenance updates) to SLES 15 SP6 (with unreleased maintenance updates).

Acceptance criteria

AC1: Provide migration from SLES 12 SP5 to SLES 15 SP6 in aggregated updates.

Actions #1

Updated by hjluo 5 months ago

  • Status changed from Workable to In Progress
  • Assignee set to hjluo
Actions #2

Updated by JERiveraMoya 5 months ago · Edited

  • Status changed from In Progress to Workable
  • Assignee deleted (hjluo)

Please @hjluo continue with your current ticket #154948 before picking another new migration in maintenance because this kind of tasks have certain complexity.
It is more efficient as a team to run them in parallel by different assignee, I hope you agree, let me know otherwise please.
Besides by design this task is completely different that the other one, because in one we add the unrelease maintenance updates in origin and here in target.

Actions #3

Updated by hjluo 5 months ago

JERiveraMoya wrote in #note-2:

Please @hjluo continue with your current ticket #154948 before picking another new migration in maintenance because this kind of tasks have certain complexity.
It is more efficient as a team to run them in parallel by different assignee, I hope you agree, let me know otherwise please.
Besides by design this task is completely different that the other one, because in one we add the unrelease maintenance updates in origin and here in target.

I'm picking it up just because my ticket #154948 was done and now it's just a few lines' effort to add a test and run the VR.

Actions #4

Updated by JERiveraMoya 5 months ago

  • Tags changed from qe-yam-feb-sprint to qe-yam-mar-sprint
Actions #5

Updated by zoecao 5 months ago

  • Status changed from Workable to In Progress
  • Assignee set to zoecao
Actions #6

Updated by zoecao 4 months ago

Learning Huajian's PR and VRs, and added testsuites of migration to SLES15SP5 for this ticket, will trigger the jobs.

Actions #7

Updated by zoecao 4 months ago · Edited

I used the SLES12SP5 image published from support image group, boot the image and register the system then upgrade it to SLES15SP5+ MU_unreleased_updates by autoyast profile.
Please correct me if I made it wrong, thanks.

Added a yaml_schedule file & an upgrade autoyast profile by PR, and running the verification:
https://openqa.suse.de/tests/overview?distri=sle&version=15-SP5&build=20240314-1&groupid=251
Still may need to adjust the yaml_schedule file and testsuites settings.

Actions #8

Updated by zoecao 4 months ago

@JERiveraMoya I update result here:
This is the latest test results: https://openqa.suse.de/tests/13790232#
I checked whether the 15-SP5 MU repos are added or not by checking the [clone-installedSystem.xml], found that only part of MU repos are added when doing migration. And the reason is that I set +SCC_ADDONS=sdk,we,contm to the testsuite. If let the case add all of MU repos, we need to set +SCC_ADDONS=MRU_ADDONS (that is we,sdk,base,script,serverapp,desktop,legacy,contm,python3), but we can not do this in this case because the job boot SLES12SP5 image and register SLES12SP5 first, while on SLES12SP5, there's no such modules like base,serverapp,python3.
So to make the migration job involve all of the 15SP5 MU repos, I will divide the one migration job to two: One is to boot SLES12SP5 image and register the system (SCC_ADDONS=sdk,we,contm); the second one is to do migration and set SCC_ADDONS=MRU_ADDONS.
WDYT? or any other solutions for this?

Actions #9

Updated by zoecao 4 months ago

I divided the one migration job to two, and triggered the jobs:
12SP5 register: https://openqa.suse.de/tests/overview?distri=sle&version=12-SP5&build=20240318-1&groupid=251
15SP5 migration: https://openqa.suse.de/tests/overview?state=assigned&state=setup&state=running&state=uploading&state=scheduled&distri=sle&version=15-SP5&build=20240318-1&groupid=251
WIll check the results later.

BTW, I have test to add MU repos manually in local VM, after migration, the MU repos are in the repo list when doing "zypper lr". SO I will continue to check why the autoyast profile didn't work in my VR.

Actions #10

Updated by JERiveraMoya 4 months ago · Edited

zoecao wrote in #note-9:

I divided the one migration job to two, and triggered the jobs:
12SP5 register: https://openqa.suse.de/tests/overview?distri=sle&version=12-SP5&build=20240318-1&groupid=251
15SP5 migration: https://openqa.suse.de/tests/overview?state=assigned&state=setup&state=running&state=uploading&state=scheduled&distri=sle&version=15-SP5&build=20240318-1&groupid=251
WIll check the results later.

BTW, I have test to add MU repos manually in local VM, after migration, the MU repos are in the repo list when doing "zypper lr". SO I will continue to check why the autoyast profile didn't work in my VR.

feel free to ask developers is that is even supported (add addon of the TARGET product (be clear about that, not the ORIGIN product, I remember the confusion last time we asked this) during autoyast upgrade), perhaps there is some AutoYaST bug, take into account they will tell you that that is not the way a customer will test it, but this is the way we add the unrealeased maintenance updates in QE, each repo as an addon, we need a way to do that or we cannot use autoyast. Does the unified installed allow you to add addons products during interactive installation? then it should be possible to do it with auto-installation, you can verify that as well.

Actions #11

Updated by zoecao 4 months ago

To update status of this ticket:
This is the latest test result for this ticket:
12SP5 register: https://openqa.suse.de/tests/13871204
15SP5 migration: https://openqa.suse.de/tests/13871208#
But MU repos are not added during migration, I already asked the question, I haven't got the answer yet.

To make the question more clearer, I created an interactive migration with additional addons repos added:
https://openqa.suse.de/tests/13872548#step/add_update_test_repo/118
and send it to help-yast channel for developers to understand the question.

Actions #12

Updated by JERiveraMoya 4 months ago

  • Tags changed from qe-yam-mar-sprint to qe-yam-apr-sprint
Actions #13

Updated by zoecao 4 months ago

Based on developer's requirement, I provided jobs with Y2DEBUG disabled to make the saved log shorter:
https://suse.slack.com/archives/C02D1T4S58S/p1711429081013739
And this is the job which works for disabling Y2DEBUG finally:
https://openqa.suse.de/tests/13906900#
Then need to wait for developer's debug for the issue (the MU repos are not in installed during migration).

Actions #14

Updated by zoecao 4 months ago

I submit PR and MR for this ticket:
https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/18932
https://gitlab.suse.de/qe-yam/openqa-job-groups/-/merge_requests/139
And please no rush to merge them, just in case any troubles caused by them, but comments are welcomed, thanks.
Still need to file a bug report to trace the AutoYaST upgrade issue, will do it after public vacation.

Actions #15

Updated by zoecao 3 months ago · Edited

Switch the testsuite to use AutoYaST, and fixing the PR based on the comments, this is new verification run:
https://openqa.suse.de/tests/overview?distri=sle&version=15-SP5&build=20240409-1&groupid=251

Actions #16

Updated by JERiveraMoya 3 months ago

zoecao wrote in #note-15:

Switch the testsuite to use AutoYaST, and fixing the PR based on the comments, this is new verification run:
https://openqa.suse.de/tests/overview?distri=sle&version=15-SP5&build=20240409-1&groupid=251

Let's keep the conversation in github, verification do not make much more sense in progress if the PR/MR is not merged (unless there is some doubt or blocking point for example, also Slack can be used for that).
We need to see the changes in the code and the verification updated there to analyze the result. Could you please update the PR according to that?

Actions #17

Updated by JERiveraMoya 3 months ago

  • % Done changed from 100 to 0
Actions #18

Updated by JERiveraMoya 3 months ago

  • Tags changed from qe-yam-apr-sprint to qe-yam-may-sprint
Actions #20

Updated by zoecao 2 months ago

I updated the PR and MR for this ticket:
https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/18932
https://gitlab.suse.de/qe-yam/openqa-job-groups/-/merge_requests/139
But yast developers is fixing the issue of AutoYaST upgrading (bsc#1223301), we could use autoyast upgrade directly when the bug is fixed.

Actions #21

Updated by JERiveraMoya about 2 months ago

Now that we have setup SP6 in maintenance, we don't need this one for SP5, if there is any change you need to do while the bug is fixed, please do it to adapt it to SP6.

Actions #22

Updated by zoecao about 2 months ago

JERiveraMoya wrote in #note-21:

Now that we have setup SP6 in maintenance, we don't need this one for SP5, if there is any change you need to do while the bug is fixed, please do it to adapt it to SP6.

Yes, I'll adapt it to 15SP6.

Actions #23

Updated by zoecao about 2 months ago

I adapt the testsuites to 15SP6, the autoyast bug is not fixed yet.
VR: https://openqa.suse.de/tests/14460424#step/zypper_lr/3

Actions #24

Updated by JERiveraMoya about 2 months ago

  • Tags changed from qe-yam-may-sprint to qe-yam-jan-sprint
Actions #25

Updated by JERiveraMoya about 2 months ago

  • Tags changed from qe-yam-jan-sprint to qe-yam-jun-sprint
Actions #26

Updated by JERiveraMoya about 1 month ago

  • Subject changed from Provide migration from SLES 12 SP5 to SLES 15 SP5 in aggregated updates to Provide migration from SLES 12 SP5 to SLES 15 SP6 in aggregated updates
  • Description updated (diff)
Actions #27

Updated by zoecao about 1 month ago

The bsc#1223301 is already fixed, and verify it: https://openqa.suse.de/tests/14593936#step/zypper_lr/3
I'm working on reset the scc_addons values. When checking the vr, the blessed modules' MU repos are not added, so still need to adjust the PR.

Actions #28

Updated by JERiveraMoya about 1 month ago

Please provide draft PR/MR when you have the time, I could help with that idea to swap the values of scc addons with those temp variables.

Actions #29

Updated by zoecao about 1 month ago

The new PR for this ticket, to swap SCC_ADDONS values doesn't work for the job. I guess the autoyast profile is generated in the very beginning of the job, so the value is not changed yet?
https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/19547
Latest vr: https://openqa.suse.de/tests/14674567#step/zypper_lr/3

Actions #31

Updated by JERiveraMoya 26 days ago

  • Tags changed from qe-yam-jun-sprint to qe-yam-jul-sprint
Actions #32

Updated by zoecao 19 days ago

PR and MR are merged, thanks!
And I filed a new ticket for the yaml schedule issue: https://progress.opensuse.org/issues/163160
I'll take a look at the test result in tomorrow's MU build, if no issues, I'll resolve this ticket.

Actions #33

Updated by JERiveraMoya 18 days ago

zoecao wrote in #note-32:

PR and MR are merged, thanks!
And I filed a new ticket for the yaml schedule issue: https://progress.opensuse.org/issues/163160
I'll take a look at the test result in tomorrow's MU build, if no issues, I'll resolve this ticket.

thanks with the persistence with this, good job!

Actions #34

Updated by zoecao 18 days ago

  • Status changed from In Progress to Resolved
Actions

Also available in: Atom PDF