Project

General

Profile

Actions

action #152673

closed

[alert] `systemctl status iscsid.socket` failed on `s390zl12.oqa.prg2.suse.org` size:S

Added by okurz 6 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
2023-12-14
Due date:
% Done:

0%

Estimated time:
Tags:

Description

martchus@s390zl12:~> systemctl --failed
  UNIT          LOAD   ACTIVE SUB    DESCRIPTION             
iscsid.socket loaded failed failed Open-iSCSI iscsid Socket

LOAD   = Reflects whether the unit definition was properly loaded.
ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
SUB    = The low-level unit activation state, values depend on unit type.
1 loaded units listed.
martchus@s390zl12:~> systemctl status iscsid.socket
iscsid.socket - Open-iSCSI iscsid Socket
     Loaded: loaded (/usr/lib/systemd/system/iscsid.socket; enabled; vendor preset: enabled)
     Active: failed (Result: resources) since Thu 2023-12-14 03:33:58 CET; 7h ago
   Triggers: iscsid.service
       Docs: man:iscsid(8)
             man:iscsiadm(8)
     Listen: @ISCSIADM_ABSTRACT_NAMESPACE (Stream)
martchus@s390zl12:~> sudo journalctl -u iscsid.socket
Dec 14 03:33:58 s390zl12 systemd[1]: iscsid.socket: Deactivated successfully.
Dec 14 03:33:58 s390zl12 systemd[1]: Closed Open-iSCSI iscsid Socket.
Dec 14 03:33:58 s390zl12 systemd[1]: Stopping Open-iSCSI iscsid Socket...
Dec 14 03:33:58 s390zl12 systemd[1]: iscsid.socket: Failed to create listening socket (@ISCSIADM_ABSTRACT_NAMESPACE): Address already in use
Dec 14 03:33:58 s390zl12 systemd[1]: iscsid.socket: Failed to listen on sockets: Address already in use
Dec 14 03:33:58 s390zl12 systemd[1]: iscsid.socket: Failed with result 'resources'.
Dec 14 03:33:58 s390zl12 systemd[1]: Failed to listen on Open-iSCSI iscsid Socket.

For now I've just restarted the unit which helped. The unit is provided by the open-iscsi package which seems to be installed on other hosts as well and also on my local TW installation. So it is probably just installed by default under openSUSE but we don't actually use it. So I guess this problem has no real impact.


Related issues 2 (0 open2 closed)

Copied to openQA Infrastructure - action #152811: ada.qe.suse.de is not responding to salt commandsResolvedokurz2023-12-14

Actions
Copied to openQA Infrastructure - action #152813: openqaw5-xen.qa.suse.de is not responding to salt commandsResolvedokurz2023-12-14

Actions
Actions #2

Updated by livdywan 6 months ago

  • Subject changed from [alert] `systemctl status iscsid.socket` failed on `s390zl12.oqa.prg2.suse.org` to [alert] `systemctl status iscsid.socket` failed on `s390zl12.oqa.prg2.suse.org` size:S
  • Status changed from New to In Progress
  • Assignee set to livdywan

Discussed it in the infra daily. I'll try and restart the service via salt to see if that reproduces the issue, and reboot a couple machines with the same goal in mind. If I can I'll report an upstream bug we can block on, otherwise I would close this ticket

Actions #3

Updated by livdywan 6 months ago

  • Copied to action #152811: ada.qe.suse.de is not responding to salt commands added
Actions #4

Updated by livdywan 6 months ago

  • Copied to action #152813: openqaw5-xen.qa.suse.de is not responding to salt commands added
Actions #5

Updated by livdywan 6 months ago

  • Status changed from In Progress to Feedback
sudo salt -C '*' --out=text cmd.run 'systemctl try-restart iscsid.socket && systemctl list-units iscsid.socket' | grep iscsid

Apparently it's successfully been restarted multiple times on all machines where it's active.

sudo salt -C '*worker14*' --out=text cmd.run 'systemctl reboot'
sudo salt -C '*s390zl12.oqa.prg2*' --out=text cmd.run 'systemctl reboot'

I picked two machines to reboot and see if that reproduces the issue. Apparently those are also fine (tickets for machines that were unresponsive before that were filed, but not related to this).

Actions #6

Updated by okurz 6 months ago

So what's your plan for this?

Actions #7

Updated by livdywan 6 months ago

  • Status changed from Feedback to Resolved

okurz wrote in #note-6:

So what's your plan for this?

As per what I mentioned before I'm resolving the ticket because it's not reproducible and I can't file an upstream ticket.

Actions

Also available in: Atom PDF