Project

General

Profile

action #15242

update Leap 42.1->TW is running out of space

Added by okurz over 5 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
High
Assignee:
michalnowak
Category:
Bugs in existing tests
Start date:
2016-12-03
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-update_Leap_42.1_kde@64bit fails to continue in
vlc after the first proceed question when the dialog shows up again.

But the actual problem is that we are running out of space.

[3 Dec 2016 17:12:08] <DimStar> also: this in the serial log gives it away:
[3 Dec 2016 17:12:09] <DimStar> [  108.791773] systemd-journald[676]: Failed to write entry (19 items, 534 bytes), ignoring: Invalid argument
[3 Dec 2016 17:12:12] <DimStar> [  119.877326] systemd-journald[676]: Failed to create new system journal: No space left on device
[3 Dec 2016 17:13:17] <DimStar> and you see similar issues when it collects the info: https://openqa.opensuse.org/tests/313227#step/vlc/77

Reproducible

Reproducible in every build for some time already

Expected result

Update and package installation should work so probably we need to recreate the images with more space.

Further details

Always latest result in this scenario: latest


Checklist

  • kde image
  • gnome image
  • cryptlvm image
  • add TOGGLEHOME=1 to {kde,gnome,minimalx,textmode,cryptvlv}-image test suites

Related issues

Related to openQA Tests - action #15406: Tumbleweed and Leap upgrade cases now run out of spaceResolved2016-12-08

History

#1 Updated by okurz over 5 years ago

  • Subject changed from test fails to continue pkcon installation in vlc after first "proceed" question to update Leap 42.1->TW is running out of space
  • Description updated (diff)

#2 Updated by okurz over 5 years ago

  • Related to action #15406: Tumbleweed and Leap upgrade cases now run out of space added

#3 Updated by okurz over 5 years ago

  • Target version set to Milestone 5

#4 Updated by michalnowak over 5 years ago

  • Assignee set to michalnowak

#5 Updated by michalnowak over 5 years ago

  • Status changed from New to In Progress

Although the Leap 42.1 KDE image in use (opensuse-42.1-x86_64-Updates-20161106-1-kde@64bit.qcow2) has 40 GB, due to separate /home partition, only a fraction of the space belongs to /.

I'll re-create the Leap 42.1 KDE image with current updates, set disk size to 22 GB (same as SLES one) and make /home part of /. Will check see if that's enough.

Open questions seems to me, whether the image should contain "lastgood" snapshot (2 GB), or, whether it should be compressed, or not. (SLES image is uncompressed, snapshot is kept.)

image: opensuse-42.1-x86_64-Updates-20170111-1-kde@64bit.qcow2
virtual size: 22G (23622320128 bytes)
disk size: 9.5G
Snapshot list:
ID        TAG                 VM SIZE                DATE       VM CLOCK
1         lastgood               1.9G 2017-01-11 14:07:36   00:27:29.035

image: opensuse-42.1-x86_64-Updates-20170111-1-kde@64bit_MAKETESTSNAPSHOTS.qcow2
virtual size: 22G (23622320128 bytes)
disk size: 6.8G

image: opensuse-42.1-x86_64-Updates-20170111-1-kde@64bit_compressed.qcow2
virtual size: 22G (23622320128 bytes)
disk size: 3.1G

#6 Updated by michalnowak over 5 years ago

Oh, I see, the upgrade to Leap 42.3 is always from the latest 42.1 image. I just need to add TOGGLEHOME=1 to {gnome,kde}-image qam-GM-{kde,gnome,cryptlvm}-install-updates test suites & a needles.

okurz: For that I need Administrator privileges, if you could grant them to me, please.

#7 Updated by okurz over 5 years ago

admin done

#8 Updated by michalnowak over 5 years ago

Old opensuse-42.1-x86_64-GM-kde@64bit.qcow2 image from Oct 31 2015:

image: opensuse-42.1-x86_64-GM-kde@64bit.qcow2
virtual size: 40G (42949672960 bytes)
disk size: 2.7G

Device     Boot    Start      End  Sectors  Size Id Type
/dev/vda1           2048  3051519  3049472  1.5G 82 Linux swap / Solaris
/dev/vda2  *     3051520 36147199 33095680 15.8G 83 Linux
/dev/vda3       36147200 83886079 47738880 22.8G 83 Linux

New opensuse-42.1-x86_64-GM2-kde@64bit.qcow2 (job: http://assam.suse.cz/tests/4669 - cloned from original GM job 97539):

image: opensuse-42.1-x86_64-GM2-kde@64bit.qcow2
virtual size: 40G (42949672960 bytes)
disk size: 2.8G

Device     Boot   Start      End  Sectors  Size Id Type
/dev/vda1          2048  3051519  3049472  1.5G 82 Linux swap / Solaris
/dev/vda2  *    3051520 83886079 80834560 38.6G 83 Linux

zdup update from Leap 42.1 GM to 20170111-1 package set: http://assam.suse.cz/tests/4670, which created opensuse-42.1-x86_64-Updates-20170111-1-kde@64bit.qcow2 image. Which was fed to: http://assam.suse.cz/tests/4673 (sort of verification run).

This should be done for Leap 42.1 GNOME and cryptlvm GM images as well.

#9 Updated by michalnowak over 5 years ago

  • Status changed from In Progress to Feedback

One way is to copy the new image to OOO's NFS, the other to re-create it on OOO itself: https://github.com/os-autoinst/os-autoinst-needles-opensuse/pull/148.

#10 Updated by michalnowak over 5 years ago

KDE image passed: https://openqa.opensuse.org/tests/333573. Will also fix 42.1 gnome and cryptlvm images.

#11 Updated by michalnowak over 5 years ago

gnome image:

  1. Create image with updates: https://openqa.opensuse.org/tests/333745
  2. Run the actual tests: https://openqa.opensuse.org/tests/333785

#12 Updated by michalnowak over 5 years ago

  • Checklist item changed from to [x] kde image, [x] gnome image, [ ] cryptlvm image, [ ] add TOGGLEHOME=1 to {kde,gnome,minimalx,textmode,cryptvlv}-image test suites

#13 Updated by michalnowak over 5 years ago

  • Checklist item changed from [x] kde image, [x] gnome image, [ ] cryptlvm image, [ ] add TOGGLEHOME=1 to {kde,gnome,minimalx,textmode,cryptvlv}-image test suites to [x] kde image, [x] gnome image, [x] cryptlvm image, [ ] add TOGGLEHOME=1 to {kde,gnome,minimalx,textmode,cryptvlv}-image test suites

cryptlvm:

  1. update of GM image: https://openqa.opensuse.org/tests/334008
  2. upgrade from updated image from (1) to 42.3: https://openqa.opensuse.org/tests/334911

#14 Updated by michalnowak over 5 years ago

  • Checklist item changed from [x] kde image, [x] gnome image, [x] cryptlvm image, [ ] add TOGGLEHOME=1 to {kde,gnome,minimalx,textmode,cryptvlv}-image test suites to [x] kde image, [x] gnome image, [x] cryptlvm image, [x] add TOGGLEHOME=1 to {kde,gnome,minimalx,textmode,cryptvlv}-image test suites

Added TOGGLEHOME=1 to {kde,gnome,minimalx,xfce,textmode,tumbleweed,cryptlvm}-image test suites on OOO. They will be effective with new builds.

#15 Updated by michalnowak over 5 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF