Project

General

Profile

Actions

action #135206

closed

[tools] GitlabCI telegraf step on salt-states-openqa failed

Added by osukup 9 months ago. Updated 9 months ago.

Status:
Rejected
Priority:
High
Assignee:
Category:
-
Target version:
Start date:
2023-09-05
Due date:
% Done:

0%

Estimated time:
Tags:

Description

https://gitlab.suse.de/openqa/salt-pillars-openqa/-/pipelines/791107

From log:

openqaworker16.qa.suse.cz:
    2023-09-05T20:00:54Z E! [inputs.ping] Error in plugin: host "walter1.qe.nue2.suse.org": exit status 2 - /usr/bin/ping: walter1.qe.nue2.suse.org: Name or service not known
    2023-09-05T20:00:54Z E! [inputs.ping] Error in plugin: host "qa-jump.qe.nue2.suse.org": exit status 2 - /usr/bin/ping: qa-jump.qe.nue2.suse.org: Name or service not known
    2023-09-05T20:00:54Z E! [telegraf] Error running agent: input plugins recorded 2 errors
    telegraf errors
worker30.oqa.prg2.suse.org:
    telegraf is fine
openqaworker17.qa.suse.cz:
    2023-09-05T20:00:54Z E! [inputs.ping] Error in plugin: host "walter1.qe.nue2.suse.org": exit status 2 - /usr/bin/ping: walter1.qe.nue2.suse.org: Name or service not known
    2023-09-05T20:00:54Z E! [inputs.ping] Error in plugin: host "qa-jump.qe.nue2.suse.org": exit status 2 - /usr/bin/ping: qa-jump.qe.nue2.suse.org: Name or service not known
    2023-09-05T20:00:54Z E! [telegraf] Error running agent: input plugins recorded 2 errors
    telegraf errors
openqaworker18.qa.suse.cz:
    2023-09-05T20:00:54Z E! [inputs.ping] Error in plugin: host "walter1.qe.nue2.suse.org": exit status 2 - /usr/bin/ping: walter1.qe.nue2.suse.org: Name or service not known
    2023-09-05T20:00:54Z E! [inputs.ping] Error in plugin: host "qa-jump.qe.nue2.suse.org": exit status 2 - /usr/bin/ping: qa-jump.qe.nue2.suse.org: Name or service not known
    2023-09-05T20:00:54Z E! [telegraf] Error running agent: input plugins recorded 2 errors

looks like some hosts have problem with dns:

openqaworker16.qa.suse.cz
openqaworker17.qa.suse.cz
openqaworker18.qa.suse.cz
openqaworker14.qa.suse.cz
qesapworker-prg4.qa.suse.cz
qesapworker-prg5.qa.suse.cz
qesapworker-prg7.qa.suse.cz
qesapworker-prg6.qa.suse.cz
openqa-monitor.qa.suse.de

AC1: pipeline pass


Related issues 1 (0 open1 closed)

Is duplicate of openQA Infrastructure - action #135230: salt pillars pipelines failing due to Temporary failure in name resolutionResolvednicksinger2023-09-06

Actions
Actions #1

Updated by okurz 9 months ago

  • Tags set to infra
  • Priority changed from Normal to High
  • Target version set to Ready
Actions #2

Updated by nicksinger 9 months ago

  • Assignee set to nicksinger
Actions #3

Updated by nicksinger 9 months ago

  • Status changed from New to In Progress
Actions #4

Updated by nicksinger 9 months ago

    2023-09-06T08:13:17Z E! [inputs.ping] Error in plugin: host qa-jump.qe.nue2.suse.org: /usr/bin/ping: qa-jump.qe.nue2.suse.org: Temporary failure in name resolution, exit status 2
    2023-09-06T08:13:17Z E! [inputs.ping] Error in plugin: host walter1.qe.nue2.suse.org: /usr/bin/ping: walter1.qe.nue2.suse.org: Temporary failure in name resolution, exit status 2

both could be related to the recent network outage and should not be caused by a faulty pipeline from us

Actions #5

Updated by nicksinger 9 months ago

  • Status changed from In Progress to Blocked
Actions #6

Updated by nicksinger 9 months ago

  • Is duplicate of action #135230: salt pillars pipelines failing due to Temporary failure in name resolution added
Actions #7

Updated by nicksinger 9 months ago

  • Status changed from Blocked to Rejected

I will continue with this in https://progress.opensuse.org/issues/135230

Actions

Also available in: Atom PDF