Project

General

Profile

Actions

action #134717

closed

salt-states-openqa pipeline fails because of telegraf checks

Added by tinita 8 months ago. Updated 8 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Regressions/Crashes
Target version:
Start date:
2023-08-28
Due date:
% Done:

0%

Estimated time:

Description

Observation

The check for telegraf config errors is not doing what we want.
Apparently in the past the pipeline was passing although there were telegraf errors, and once all those were fixed, the pipeline started to pass, so the logic was doing the opposite.

I tried to fix it with this MR:
https://gitlab.suse.de/openqa/salt-states-openqa/-/merge_requests/943 (merged)

However I missed that there is an exclamation mark at the start of the telegraf command, and this is not doing what we want.
Also my test for an empty logfile didn't work because there are more lines landing in that logfile, so now I hope I fixed both issues with this MR:
https://gitlab.suse.de/openqa/salt-states-openqa/-/merge_requests/945

Actions #1

Updated by tinita 8 months ago

  • Status changed from Feedback to Resolved

It looks like it's doing the right logic now. Resolving

Actions #2

Updated by tinita 8 months ago

Actions

Also available in: Atom PDF