Project

General

Profile

Actions

action #133928

closed

salt-states-openqa | Failed pipeline for master

Added by tinita 9 months ago. Updated 9 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
-
Target version:
Start date:
2023-08-07
Due date:
% Done:

0%

Estimated time:

Description

https://gitlab.suse.de/openqa/salt-pillars-openqa/-/jobs/1741006
ERROR: Job failed: exit code 1

I can't find any error in the log.


Related issues 1 (0 open1 closed)

Related to openQA Project - action #133979: test fails in openqa_webuiResolvedokurz2023-08-08

Actions
Actions #1

Updated by okurz 9 months ago

  • Tags set to infra, alert, salt
  • Priority changed from Normal to High
  • Target version set to Ready
Actions #2

Updated by livdywan 9 months ago

I also couldn't see any errors, but in this MR failing in test-worker I did:

ID: worker.packages
    Function: pkg.installed
      Result: False
     Comment: Attempt 1: Returned a result of "False", with the following comment: "An error was encountered while installing package(s): Zypper command failure: Loading repository data...
              Reading installed packages...
              Resolving package dependencies...

              Problem: nothing provides 'perl(:MODULE_COMPAT_5.36.1)' needed by the to be installed perl-Test-Assert-0.0504-9.29.noarch
               Solution 1: do not install os-autoinst-distri-opensuse-deps-1.1691486617.e4729ec0-12624.1.noarch
               Solution 2: break perl-Test-Assert-0.0504-9.29.noarch by ignoring some of its dependencies

              Choose from above solutions by number or cancel [1/2/c/d/?] (c): c"
              Attempt 2: Returned a result of "False", with the following comment: "An error was encountered while installing package(s): Zypper command failure: Loading repository data...
              Reading installed packages...
              Resolving package dependencies...

              Problem: nothing provides 'perl(:MODULE_COMPAT_5.36.1)' needed by the to be installed perl-Test-Assert-0.0504-9.29.noarch
               Solution 1: do not install os-autoinst-distri-opensuse-deps-1.1691486617.e4729ec0-12624.1.noarch
               Solution 2: break perl-Test-Assert-0.0504-9.29.noarch by ignoring some of its dependencies

              Choose from above solutions by number or cancel [1/2/c/d/?] (c): c"
              Attempt 3: Returned a result of "False", with the following comment: "An error was encountered while installing package(s): Zypper command failure: Loading repository data...
              Reading installed packages...
              Resolving package dependencies...

              Problem: nothing provides 'perl(:MODULE_COMPAT_5.36.1)' needed by the to be installed perl-Test-Assert-0.0504-9.29.noarch
               Solution 1: do not install os-autoinst-distri-opensuse-deps-1.1691486617.e4729ec0-12624.1.noarch
               Solution 2: break perl-Test-Assert-0.0504-9.29.noarch by ignoring some of its dependencies

              Choose from above solutions by number or cancel [1/2/c/d/?] (c): c"
              Attempt 4: Returned a result of "False", with the following comment: "An error was encountered while installing package(s): Zypper command failure: Loading repository data...
              Reading installed packages...
              Resolving package dependencies...

              Problem: nothing provides 'perl(:MODULE_COMPAT_5.36.1)' needed by the to be installed perl-Test-Assert-0.0504-9.29.noarch
               Solution 1: do not install os-autoinst-distri-opensuse-deps-1.1691486617.e4729ec0-12624.1.noarch
               Solution 2: break perl-Test-Assert-0.0504-9.29.noarch by ignoring some of its dependencies

              Choose from above solutions by number or cancel [1/2/c/d/?] (c): c"
              An error was encountered while installing package(s): Zypper command failure: Loading repository data...
              Reading installed packages...
              Resolving package dependencies...

              Problem: nothing provides 'perl(:MODULE_COMPAT_5.36.1)' needed by the to be installed perl-Test-Assert-0.0504-9.29.noarch
               Solution 1: do not install os-autoinst-distri-opensuse-deps-1.1691486617.e4729ec0-12624.1.noarch
               Solution 2: break perl-Test-Assert-0.0504-9.29.noarch by ignoring some of its dependencies

              Choose from above solutions by number or cancel [1/2/c/d/?] (c): c
     Started: 17:19:29.613579
    Duration: 123694.789 ms
Actions #3

Updated by livdywan 9 months ago

Actions #4

Updated by livdywan 9 months ago

  • Status changed from New to Feedback
  • Assignee set to livdywan

I'm grabbing the ticket to track it. Likely this will be resolved by another snapshot, worst case we end up discovering more packaging issues. Either way we can only wait for now.

Actions #5

Updated by livdywan 9 months ago

  • Status changed from Feedback to Blocked

Blocking on #133457

Actions #6

Updated by okurz 9 months ago

  • Status changed from Blocked to Resolved

#133457 resolved. With this also the pipeline is again in a good state and passing. Ticket resolved.

Actions

Also available in: Atom PDF