Project

General

Profile

Actions

action #131102

closed

[openQA-in-openQA] test fails in test_running

Added by tinita 10 months ago. Updated 10 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Regressions/Crashes
Target version:
Start date:
2023-06-19
Due date:
% Done:

0%

Estimated time:

Description

Observation

openQA test in scenario openqa-Tumbleweed-dev-x86_64-openqa_install+publish@64bit-2G fails in
test_running

# Test died: command 'retry -s 30 -r 5 -- openqa-cli api jobs state=running state=done | ack --passthru --color "running|done"' failed at /usr/lib/os-autoinst/autotest.pm line 387.

It returns an empty list of jobs, so no jobs are currently running or finished.

Test suite description

Maintainer: okurz@suse.de Test for installation of openQA itself. To be used with "openqa" distri. Publishes an qcow2 image including the openQA installation ready to run as an appliance.

Reproducible

Fails since (at least) Build :TW.21064 (current job)

Expected result

Last good: :TW.21061 (or more recent)

Further details

Always latest result in this scenario: latest

Actions #1

Updated by tinita 10 months ago

  • Project changed from openQA Tests to openQA Project
  • Category changed from Bugs in existing tests to Regressions/Crashes
Actions #3

Updated by tinita 10 months ago

How is that pull request related to that failure?
I assume it's related to this failure https://openqa.opensuse.org/tests/3350077#step/test_running/12 from this issue: #127622

Actions #4

Updated by okurz 10 months ago

  • Target version set to Ready
Actions #5

Updated by tinita 10 months ago

  • Status changed from New to In Progress
  • Assignee set to tinita
Actions #6

Updated by tinita 10 months ago

I noticed that the retry call actually didn't retry because it took just a few seconds.

https://github.com/os-autoinst/os-autoinst-distri-openQA/pull/129 Fix usage of retry

Somehow I remember having fixed a similar thing in the past, but can't find it anymore...

Actions #7

Updated by tinita 10 months ago

  • Status changed from In Progress to Feedback
Actions #8

Updated by tinita 10 months ago

  • Status changed from Feedback to Resolved
Actions

Also available in: Atom PDF