Project

General

Profile

Actions

action #127565

closed

[qe-core][leap 15.4 backports]test fails in setup_online_repos

Added by rfan1 about 1 year ago. Updated 11 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
Start date:
2023-04-13
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-15.4-DVD-Backports-Incidents-x86_64-install_with_updates_gnome@64bit-2G fails in
setup_online_repos

Test suite description

Reproducible

Fails since (at least) Build 20230412-2

Expected result

Last good: 20230412-1 (or more recent)

Further details

Always latest result in this scenario: latest

Actions #1

Updated by rfan1 about 1 year ago

The issue should be caused by https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/16829:

commit b004c4f0d2507488ce2f3534553c6c4d7e744727 (upstream/master)
Author: Fabian Vogt <fvogt@suse.de>
Date:   Tue Apr 11 17:26:00 2023 +0200

    tests/installation/online_repos: Expect repo list screen after enabling

diff --git a/tests/installation/online_repos.pm b/tests/installation/online_repos.pm
index 583cd5ab9..3a7f9c33c 100644
--- a/tests/installation/online_repos.pm
+++ b/tests/installation/online_repos.pm
@@ -67,6 +67,8 @@ sub run {
     } elsif ((is_livecd && !get_netboot_mirror) || installwithaddonrepos_is_applicable()) {
         # Acivate online repositories
         wait_screen_change { send_key 'alt-y' };
+        assert_screen('list-of-online-repositories');
+        send_key $cmd{next};
     } else {
         # If click No, step is skipped, which is default behavior
         wait_screen_change { send_key 'alt-n' };

Actions #2

Updated by favogt about 1 year ago

  • Status changed from New to In Progress
  • Assignee set to favogt
Actions #3

Updated by rfan1 11 months ago

  • Status changed from In Progress to Resolved
Actions

Also available in: Atom PDF